Recent Posts

Pages: [1] 2 3 ... 10
Boot Managers / Re: Can't change to graphics-mode
« Last post by Tanzmusikus on May 26, 2017, 00:15:27 AM »
Yes, I'll do.

So I wish you the best for the "New Boot Manager" !!  8)
The GUI is lookin' fine, but yes the inside is more important.

Best regards, TM
Boot Managers / Re: Can't change to graphics-mode
« Last post by Elmar on May 25, 2017, 23:15:26 PM »
Thanks for your info. I am pretty sure that the upcoming release can handle it fine. I would be happy when you check it with trying the test version when its available. But I cannot send you an extra mail for testing. So you have to check out from time to time the website or join the newsletter or the more personal/private twitter account.

Best regards
Boot Managers / Re: Can't change to graphics-mode
« Last post by Tanzmusikus on May 25, 2017, 21:26:29 PM »

thanks for your reply!

On my older PCs with DDR2 and non-Next-Generation GPUs (ATI HD 4k, 5k, 6k) there is no problem.
On my 990FX-board there is a AMD R9 290X.

Maybe it helps you for developing.

Bye, TM
Boot Managers / Re: Can't change to graphics-mode
« Last post by Elmar on May 25, 2017, 19:58:09 PM »

maybe its a problem with the init routine of the graphic mode. The new boot manager will be more dynamic in this matter, but it will not be fixed in the 5.0.x series.

Best regards
Boot Managers / Can't change to graphics-mode
« Last post by Tanzmusikus on May 24, 2017, 18:44:49 PM »
Hello Elmar,

I can't find the cause of problem ... nor a solution.

On ASRock 990FX Extreme6 mainboard I cannot change to graphics-mode.
It stays on 80x50 Textmode with gray squares.
But I like the starfield simulation !!

What I did & tried:
- prepared plpbt.bin with the gui and started it from the Boot-Menu in Windows7 (64bit),
- installed from CD, both last versions (5.0.14 & 5.0.15),
- renewed MBR,
- unmounted all other hardware-drives (HDDs, SSDs),
but I could'nt change - not with keyboard action-keys (Alt+Bild) & not within the Menu.

Could it be, that the Samsung 850 Pro (SATA3) is write-protected against viruses?
Or what could it be?

I could change all other things and there were saved fine.
That's why, it could not be something like write-protection.

What else could I do?

Regards, TM
Thank you very much!

I assumed 8192 for my 3TB drive, but it appears 4096 is correct, as I did manage to get a partial restore of the file when calculating and specifying a block size of 4096 just now. I did try this earlier with no luck, so must have made a mistake in my calculation or command line.

As the file appears to be fragmented, I guess I will make some attempts at getting the Extents Overflow File from the formatted drive.
Are you sure that you had a block size of 8192 bytes and not 4096?
I am probably misunderstanding something, so I'll try a question here:

I have an accidentally formatted external USB-drive (3TB).
I have run ./hfsprescue -s1 and -s2, filenames have been found, but attempting a restore with -s3 produces garbage files, so I assume I need an offset value for the restore. I have not been able to get that to work.

I am using hfsprescue 3.3 2017/03/3 on macOS 10.12.5

I have tried finding the partition offset using the procedure at with two different reference files, and both file patterns have been found, but don't think I am able to interpret or use the results correctly. Both files give the same negative number as the result:

For one file I get the following:

$ ./hfsprescue --list | grep DSCN1749_rotation.JPG
13245: DSCN1749_rotation.JPG, 1212395 bytes, 1099222886, Sun Oct 31 12:41:26 2004, Start block 4821307

$ sudo ./hfsprescue --find /dev/disk6s2 -ff 8192 DSCN1749_rotation.JPG
File DSCN1749_rotation.JPG: Bytes found at offset 39390806016 + 483328 = 39391289344 (0x92be00000 + 0x76000 = 0x92be76000)

But using the formula (offset = byte_search_result - list_start_block * block_size) I get a negative value:
39391289344 - 4821307 * 8192 = -104857600

I assume that is not correct? If someone can shed some light on it it would be greatly appreciated.

(If I manage to understand what is going on here, I also seem to have an issue with getting --one-file and the offset switch -o to work at all, but I will get back to that if I manage to calculate the offset correctly.)
Boot Managers / Re: wont boot from usb
« Last post by vesalocal on April 30, 2017, 22:49:54 PM »
Over here the link works (I'm logged in and used the link from my first reply).
However, simply search " Toshiba Portege 3020CT"

Boot Managers / Re: wont boot from usb
« Last post by appletechgeek on April 30, 2017, 22:03:32 PM »
Link doesnt work it goes to the home page however it boots from my 256 mb usb stick just fine (depends what you call fine) it stil gets stuck alot
Pages: [1] 2 3 ... 10