Author Topic: plop5.0.6 noemul.iso / isolinux3.83 + plpbt.bin vmware fusion 3.0.1 (SOLVED)  (Read 7423 times)

walterav

  • Jr. Member
  • **
  • Posts: 61
This error looks very familiar:
http://forum.plop.at/index.php/topic,84.0.html

When I create my own custom-distro, I added plpbt.bin to /isolinux/ and changed the name to plpbt. Also I added the boot parameters to isolinux.cfg. It works on a native machine, it also worked with plop5.0.5 bin in vmware-fusion we tested it before.

But the plop5.0.6 bin does not boot anymore in vmware-fusion 3.0.1. As soon as I choose plopbootmanager from the isolinux menu, vmware gives a error message:
The master boot record (MBR) of this virtual machine's harddisk does not contain valid bootstrap code.
blablablalbalba
"http://vmware.com/info?id=18"
Than I can press okay and it will shutdown the virtual machine.

The bootmanager 5.0.6 plpbt.bin does boot on the native hardware integrated in the custom-distro isolinux.
« Last Edit: December 29, 2009, 12:17:08 PM by walterav »

walterav

  • Jr. Member
  • **
  • Posts: 61
The plop5.0.6 plpbt.iso is able to boot in vmware fusion 3.0.1

But the plop5.0.6 plpbtnoemul.iso is NOT.
Since I use the same way of plpbt.bin integration into isolinux as the plpbtnoemul.iso both use the same binary I noticed, I might suspect its a bug?

The noemul.iso says:
Isolinux3.73 etc etc
Loading plpbt.bin...Ready.

Than it hangs, ctrl-alt-del still works and restarts the machine
« Last Edit: December 27, 2009, 11:38:45 AM by walterav »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: plop5.0.6 noemul.iso / isolinux3.83 + plpbt.bin vmware fusion 3.0.1 errors
« Reply #2 on: December 27, 2009, 12:44:23 PM »
ok, i can reproduce the mbr stuff. i look whats wrong

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: plop5.0.6 noemul.iso / isolinux3.83 + plpbt.bin vmware fusion 3.0.1 errors
« Reply #3 on: December 27, 2009, 13:20:20 PM »
ahhh shit. such a dumb bug.
here is a test version.

walterav

  • Jr. Member
  • **
  • Posts: 61
Re: plop5.0.6 noemul.iso / isolinux3.83 + plpbt.bin vmware fusion 3.0.1 errors
« Reply #4 on: December 29, 2009, 12:16:39 PM »
ahhh shit. such a dumb bug.
here is a test version.

It directly tried the 5.0.7 version and it works! Didn't try the test version.
Thanks for the fix.
« Last Edit: December 29, 2009, 12:18:15 PM by walterav »