Author Topic: Run PLoP from CD but can't boot usb  (Read 20640 times)

bralmu

  • Newbie
  • *
  • Posts: 5
Run PLoP from CD but can't boot usb
« on: July 23, 2009, 14:26:38 PM »
Hi,

I have a Laptop without harddisk (Toshiba with Celeron1.6/512MB/DVD).
The bios doesn't support boot from USB so I tried PLoP.

I burned PLoP into a CD-RW. The program works but here comes the problem:

1) The program loads (with the stars moving in background).
2) I select USB and press enter.
3) A new screen says:
LOADING EHCI DRIVER
SEARCHING ON HOSTS
HOST 1

After that the background stars stops and the laptop get frozen (ctrl+alt+del doesnt work only power button).

I repeated this several times with the usb stick connected, disconnected, connected since power on, connected since PloP is loaded. Always happens the same thing.
Any ideas or suggestions?

PS: I'm trying to boot Ubuntu/Xubuntu from a USB in a laptop (without usb-boot bios support). If I can't with PLoP, is there any other alternative? I don't want to throw my computer in the garbage just because the harddisk died.

« Last Edit: July 23, 2009, 14:29:55 PM by bralmu »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #1 on: July 23, 2009, 15:06:57 PM »
hi,
what happens when you press SHIFT and U to force usb 1.1 without any usb device connected?

what is the exact laptop name?

regards
elmar

bralmu

  • Newbie
  • *
  • Posts: 5
Re: Run PLoP from CD but can't boot usb
« Reply #2 on: July 24, 2009, 16:30:23 PM »
I've try today. It happens the same thing.

Toshiba Tecra M1
MODEL NO. PT930E-03YQW-EN
SERIAL NO. X3550533G
PM 1.6GHZ / 2X256 / 40GB / 14"


According to this page it has a Intel 855PM motherboard chipset
http://asia.cnet.com/reviews/hardware/notebooks/0,39001745,39013020p,00.htm

This page have more hardware details
http://linux.toshiba-dme.co.jp/linux/eng/pc/tecraM1_report.htm

I tried Ubuntu 9.04 livecd and it works perfecty (except video need to be reconfigured) and I check usb ports are working. I connected 2 usb sticks and transfer data from one to other @ 3.8MB/s so I'm sure they are usb2.0 ports.
« Last Edit: July 24, 2009, 16:42:54 PM by bralmu »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #3 on: July 24, 2009, 16:40:14 PM »
please test if the cdrom boot option of my boot manager works with your laptop.

bralmu

  • Newbie
  • *
  • Posts: 5
Re: Run PLoP from CD but can't boot usb
« Reply #4 on: July 24, 2009, 16:57:21 PM »
LOADING CDROM DRIVER
DW-224E
WAITING FOR THE DRIVE...
LOADING BOOT SECTOR...


...........................................................................................
............
 and PLoP again


CDROM works but USB dont. How unlucky I am  :'(

bouba

  • Newbie
  • *
  • Posts: 2
Re: Run PLoP from CD but can't boot usb
« Reply #5 on: July 24, 2009, 17:12:32 PM »
I have exactly the same problem. But it works sometimes...

I tried with several distributions on differents PCs with the same result.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #6 on: July 24, 2009, 17:18:36 PM »
here is a test version. the link is only temporary!
http://download.plop.at/files/tmp/plpbt.iso

how many "x" do you see on the top of the screen when you try usb without any device connected.


bouba

  • Newbie
  • *
  • Posts: 2
Re: Run PLoP from CD but can't boot usb
« Reply #7 on: July 24, 2009, 17:39:25 PM »
I don't have any "x". I have just an error to say there's non device (in red).


Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #8 on: July 24, 2009, 17:50:25 PM »
oh, i uploaded the wrong version. download it again.

@bouba:
try it on the computer where it hangs with this output
LOADING EHCI DRIVER
SEARCHING ON HOSTS
HOST 1

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #9 on: August 02, 2009, 12:49:35 PM »
no answers, no solutions :(

bralmu

  • Newbie
  • *
  • Posts: 5
Re: Run PLoP from CD but can't boot usb
« Reply #10 on: August 02, 2009, 16:11:17 PM »
Finally I bought a new harddisk for the laptop.
I'm busy but maybe tomorrow I'll try the ISO you linked me.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #11 on: August 11, 2009, 20:08:09 PM »
hi,
do you have any news for me?

schlingel

  • Newbie
  • *
  • Posts: 3
Re: Run PLoP from CD but can't boot usb
« Reply #12 on: August 14, 2009, 00:04:13 AM »
Hi Elmar,

thanks for the great application and your support!
I habe the same issue here: Just downloaded your debug version above and booted from it.
In the selection menu I press Shift+U (without the thumbdrive or any other USB device connected)

It says
Loading UHCI Drivers
Searching on Hosts
Host 1
Host 2
Host 3


and then in red:
*** Boot Error ***
No boot device found, Please retry it


No X-es or any other useful output.

If I start with the USB Key connected it stalls at "Loading Boot sector" both with the standard settings and with "enforce USB 1.1"

Any advice? :(

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #13 on: August 14, 2009, 10:54:07 AM »
hi schlingel,
its not the same problem like above. the problem above is with the ehci driver and not with the uhci driver. i think your problem will be fixed with the upcoming release.

regards
elmar

schlingel

  • Newbie
  • *
  • Posts: 3
Re: Run PLoP from CD but can't boot usb
« Reply #14 on: August 14, 2009, 10:56:56 AM »
Oh, true. Thanks :)

Reading closely helps sometimes  ;D

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #15 on: August 14, 2009, 14:13:31 PM »
@schlingel
you can try this new test version
http://download.plop.at/files/tmp/plpbt-test.zip

MartinS

  • Newbie
  • *
  • Posts: 12
Re: Run PLoP from CD but can't boot usb
« Reply #16 on: August 21, 2009, 09:42:50 AM »
I have the same problem with the EHCI driver (system hangs) and would like to help debugging the problem because of selfish reasons. ;-)

jqou

  • Newbie
  • *
  • Posts: 19
Re: Run PLoP from CD but can't boot usb
« Reply #17 on: August 30, 2009, 16:04:37 PM »
Hi,

I have the problem as well. My hardware is also a Toshiba Notebook (Satelllite 5200-903 from 2003). If you provide a software with debug traces I will test it for you... So hopefully the problem can be fixed. Please let me know ...

schlingel

  • Newbie
  • *
  • Posts: 3
Re: Run PLoP from CD but can't boot usb
« Reply #18 on: September 16, 2009, 02:50:29 AM »
@schlingel
you can try this new test version
http://download.plop.at/files/tmp/plpbt-test.zip
Sorry, was away for some time and forgot about it all.

Could you please upload the file again. I'd test then.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: Run PLoP from CD but can't boot usb
« Reply #19 on: September 16, 2009, 13:24:38 PM »