need help to boot usb on old Toshiba Satellite 2595xdvd

Started by zapp, April 16, 2011, 22:57:40 PM

Previous topic - Next topic


I have an old laptop that I am trying to boot xp through USB and plop with no success so far. I hope somone can help.

Im using plop v5.0.11

Laptop is Toshiba Satellite 2595xdvd

it has Celeron 200mhz processor and 200mb RAM available

Intel R 82371AB/EB PCI to Universal host controller.

an odd thing I have noticed is when booting xp through onboard HDD and opening "device manager" and viewing by connection I see a "root usb hub" between the host controller and usb mass storage device.

this laptop only has one usb socket/port, Im sure it is usb1.1 since the laptop is old however this port is not through one of the available PCI slots, it is by itself.

I have tried to boot several working USB devices with it, both USB HDD and USB Flash. the results are inconsistent, many times I have got as far as the XP boot.ini screen but most times plop freezes after I click "usb"

I have tried "setup"> "bootmanager" thenselecting usb mode 1 and mode 2 and also "use usb massstordev" 01,02,03,04,etc. in every combination.

I have tried plop from floppy and cdrom but not directly on HDD yet, should I try HDD and if so through the boot.ini install method or other?

or does anyone have any suggestions I can try?

I'd really like to get this working because this laptop is able to run directly from 12vdc and I can use it in an off-grid, solar PV environment without the need for an ac converter/adapter and this is the only unit I have found so far that can run directly off 12vdc.

if there is additional info I can provide that may help then let me know.



Hello zapp,

I don't think a HD install will help you!

Try other versions 5.0.10 and if you downloaded the test version 5.012 (is no longer on the home page)

Hope that one will let you boot via usb on one way or another.



hi Jan4, I had v5.0.7 on a floppy so I tried that and now I can get the boot.ini screen everytime but usually that is it and it freezes but it did go past that and start loading ntkernl a couple of times and once it loaded all the drivers after ntkrnl too but it still did not boot and froze after all the drivers loaded.

Im not sure what is goin on..



Looks like v5.0.7 is working ok!

The thing i think is going on is, your laptop is having only USB1.0 and data is to slow for windows XP.

Try booting linux or good old dos.
Else if you only have USB1.0 get plop V5.0.10 (and or V5.011-2 os V5.0.12) and make a flop with pcmcia support, and boot that!
If pcmcia port is seen and you get to the bootmanager (on my siemens plop is hanging ) .
If you have a pcmcia card remove ik during this test!!

If that's going ok , then buying a USB2.0 pcmcia card probably will solve your problem , here in the nederlands you can get one for about 20 euro.

P.S try plop V5.0.10 first I recall i had a problem with an ealy version of plop i don't know witch hat was booting slow!

Hope this helps


hi Jan4

yes, it is USB1.1 and linux and DOS boots OK.

I think it is a built in pcmcia card between my USB port and host contoller, I cant remove it. the laptop has two external pcmcia slots also so I may try your suggestion and find a usb2 card but Ive seen it load all the system32 drivers once so its close to booting now.



a standard xp is unable to boot from usb.

you need usboot, bartpe for usb or similar to boot xp from usb



Hi zapp,

I Never tryed to boot windows from USB only from cd and there is had the problem with speed.
Do you have a version for usb and does it run on another system ?

Your USB on a normal laptop is NOT going via pcmcia!!
If you have no cards in your pcmcia slots , dat's fine.
(I need on my old laptop a pcmcia network card to be able to go on the internet, and if the card is there plop is locking after seeing that card.)

So if the SPECIAL PCMCIA plop is running on your system it can be usefull to by an pcmcia usb2.0 card.

USB 1.1 is not that slow ( USB1.0 is verry slow).

regars jan.


hi Elmar,

this is a Usboot xp. yes Jan4, it works in many systems.. all of them I have tried that support booting from usb and a couple that do not thanks to Elmar/Plop!

just having trouble with this one. I may try a pcmcia as you suggest at some point if I cant get it working.

this is a side project anyway. right now Im learning to ram load xp from usb and its a bit overwhelming. I have had some success though but not with my main system with the tricky ICH9 controller.




yes! 5.0.12 did it!

Elmar you are great! thanks to you many of us can put old hardware to good use.

thanks again, this make four old systems Plop makes booting usb possible in now for me. I didnt have to buy anything and have direct contact with the developer too.

I read at Bootland/reboot that you are changing the licence for comercial user to pay. I think thats good! you desrve alot for your work, you make many things possible for many people.

I hope you keep sharing with private/non comercial users but your work is worth something to us also so if that changes I would be glad to pay something.

just being able to boot this machine here has saved me time, money and so far I havnt found another system that works directly from 12vdc. Im sure there are others but oddly 12 volt systems are somewhat rare.

thanks again Elmar! You are Top Class.