problem accessing floppy from CD boot

Started by gld59, February 12, 2012, 10:07:09 AM

Previous topic - Next topic


I didn't see the forum until I'd already sent this to Elmar,  :-[ so here's a copy and paste.

QuoteHi Elmar,
I'm not sure whether this little glitch is caused by the Plop Boot Manager, FreeDOS, SpinRite, or something else, but I thought I should tell you.

My older computer is built around the Abit BH6 motherboard, which is based on the Intel 440BX chipset. As it is way too old to have USB booting included in the BIOS (and the BIOS only allows a choice between several fixed-order lists anyway), I decided to replace the Ranish Partition Manager I had been using with Plop Boot Manager, initially 5.0.13 and now 5.0.14. (As a replacement for Ranish, it is of course installed to the MBR.) In most situations things work as they should.

However, I was recently handed a large pile of floppy disks which needed data recovered from them - many were damaged, so I pulled out a SpinRite CD to assist. (SpinRite uses FreeDOS as its OS.) When booting from this CD via Plop Boot Manager, the floppy drive was not visible. Changing the BIOS settings to boot directly from CD made the floppy drive visible again from SpinRite. I thought I should test at least one other parameter, so I tried a Puppy Linux CD (Racy 5.2.2), booting via Plop Boot Manager - this can see the floppy drive.

(I also have a bootable USB flash drive with the MS-DOS from Windows 98 (7.1 ?), and SpinRite added to it. This sees the floppy drive from DOS, but SpinRite will not start correctly - it hangs while "Discovering System's Mass Storage Devices".)

As you can see, I really don't know where in this tangled mess the problem lies. (Perhaps SpinRite is expecting something to be very strictly defined, about which Linux and MS-DOS are more relaxed?)

It's obviously not a critical issue, even if you're "at fault". (Yeah right, you could be "at fault" for something so non-dangerous in a useful program you provide for free?) ::roll:: I can't think of anything else useful at the moment, but I may try to find other things to test.

Since I wrote that, I've found the problem may also be specific to that hardware. Though I haven't installed Plop Boot Manager on my newer computer, I've booted it from the SpinRite USB flash drive, without SpinRite hanging.

I've had a bit of a trawl through the forum, without finding this problem mentioned. (Just my silly old machine, or just nobody else has discovered it?) Perhaps if others can replicate this, it could help narrow down what's causing it.



Quote from: gld59 on February 12, 2012, 10:07:09 AM
... so I tried a Puppy Linux CD (Racy 5.2.2), booting via Plop Boot Manager - this can see the floppy drive. ...

puppy linux is no valid test, because linux is using its own drivers and has an own hardware detection process. dos is using the bios / bios data area to access / detect hardware when you dont have additional device drivers.

what drive letter do you see when FreeDOS is booted from cd?

best regards


SpinRite bundles FreeDOS - the initial Windows program you buy then creates the bootable CD (or floppy) itself, so the CD is single-purpose. I've tried to use Ctrl-C to stop SpinRite, but that doesn't work.

I'll have to create a plain FreeDOS CD to try, but I won't get a chance to do that until tomorrow. Sorry - I should have thought of that one myself. (At least the FreeDOS iso file shouldn't take too long to download, even on my rather slow connection.) ;D



Quote from: gld59 on February 12, 2012, 11:11:50 AM
SpinRite bundles FreeDOS - the initial Windows program you buy then creates the bootable CD (or floppy) itself

when the created cd boots in floppy emulation mode then my driver emulates a floppy drive with the image on the cd. this virtual drive became the first floppy drive and the first internal drive became the second floppy drive. maybe there is a problem with accessing the internal drive with my driver. the driver is very old. i think that the internal floppy drive access worked well with the driver when the floppy emulation is used. but i did not test such a situation for a long time.


Bingo! You've saved one piece of plastic being used up as a CD.  :)

On a previous occasion, I had to use SpinRite on 5.25" floppies, so I bought and connected the appropriate drive. I found out rather quickly that SpinRite assumes very strongly that there is only one floppy drive - the new and exciting worlds of weirdness I saw, until I completely disconnected whichever one was not being used, made my brain hurt. ::)

I'd say that makes it at least 95% likely that my problem happens because SpinRite can't handle your entirely reasonable method of providing CD access. Thanks for nailing it down so quickly.