boot from usb drive 1 that will start boot for usb drive 2

Started by sbh, November 15, 2013, 20:26:32 PM

Previous topic - Next topic



I have a gigabyte motherboard that has a problem to start some linux master boot records on usb drive, but its work fine with other usb drive like usb drive with windows MBR.

to solve this issue I come with the idea to take usb drive 1 and install on it PLoP linux that start a menu, in the menu I can start plop linux or plop boot Manager.
I set it up that the default option is the plop boot Manager. (until this point every thing work as plan)
After 10 seconds plop boot manager is started and I get the menu with all the partitions.
(I have HDA par 1, HDB par 1, HDC par 1 and 2, Floppy, CDROM, USB, NETWORK)

I want to be able to load a second bootable usb drive from this menu.

I choose from the list the usb, in this point instead loading the second usb drive it load the same usb drive and I get back to the same menu that I had when I just loaded the usb drive 1 just this time the keyboard if not reacting.

I tried to play with the plpbt.bin
and set the Use USB Device option from 1 to 2 with no success.
I verified that the second usb drive is bootable and when I plug it to the computer directly without the plop I can boot it.

If any one know how to boot second usb drive from first usb drive with plop I will be great help.



If you hit Control (or is it Shift?) while you select USB, plop will ask you whether the first device it finds is OK, or if it has to search again, etc. until you accept.


I tried it, it was the shift, but till it not let me to boot from any other device.
I tried the device directly without all the syslinux and it boot.
the image on the device is xpenology that use grob2 as much as I know.


Quote from: sbh on November 17, 2013, 00:30:21 AM
I tried it, it was the shift

I double-checked and it looks like you're wrong. See

QuoteSpecial additional keys for USB boot:

Press SHIFT-u to force USB 1.1

Press CTRL-u to wait for a key press before starting the operating system. When a drive was found, then you can press "s" to skip the device or you can boot from the drive.

Press ALT-u to wait for a key press before detecting the usb device type. When a device was found, then you can press "s" to skip the device or you can boot from the device when it's as mass storage device.

Difference CTRL-u and ALT-u:
When you use CTRL-u and the boot manager finds an usb device, then the boot manager identifies it. Because of the stripped down usb implementation, it's possible that the boot manager sometimes hangs on some computers. With ALT-u, the identification of the usb drives happens when you press enter. When you press "s", then the boot manager skips the device and it should not hang.


Hi Lev,

First I want to thank you for the help.

I tried shift and control, in each one of them I get in the end error that said, no boot device.
to make sure that its not a usb device issue I did the next steps:
1) USB drive 1 - installed the syslinux and plop boot manager and let it run to make sure that it start from boot.
2) USB drive 2 - formatted it with HP usb boot disk utility with win98boot and test it by it self that it boot to dos prompt.
3) USB drive 3 - install on it Linux Ubuntu live and test it to make sure it boot to Linux.

in this point I have 3 usb drive that all working and booting when I choose from the bios option.

now I inserted two usb drives to the computer and start it.
I choose to start from the plop usb drive and I got the menu (the second usb was the dos usb).
from the menu I choose the boot manager and i got list of devices to boot from.
In this point I did multiple testing:
1) I choose USB
2) I pressed shift and choose USB
3) I pressed ctrl and choose USB
None of the cases load the other USB drive.

I repeat on the same test with the plop usb and the other usb (linux usb)
same as the previous.

on 2 and 3 in the multiple testing I got error that there are no boot device.
on the first I got back to the same menu again and again.



Just in case: do drives 2 & 3 have the bootable flag on?
I know some BIOSes ignore it; if plop doesn't, that could be the explanation.


if you talk about the boot flag, then yes both has the boot flag on, verified with fdisk -l