Author Topic: Please help - Cannot boot from Plop on one of two machines  (Read 5204 times)

Conker2014

  • Newbie
  • *
  • Posts: 1
Please help - Cannot boot from Plop on one of two machines
« on: March 12, 2014, 16:15:47 PM »
First of all, thanks for the Plop Boot Manager, as it helped me solve a problem on my nephew's netbook. However, I can't get it to work on my laptop.

My nephew has a HP DM1 4402sa netbook, which came with Windows 8. He hates Windows 8 (who doesn't?), and asked me to put Windows 7 on there, but it turns out that there are two different versions of this netbook, one that runs Windows 7, and one with slightly different internals that is Windows 8 only, and HP's helpdesk were no help with finding compatible drivers. I managed to put Windows 7 on there, and everything (sound, 3D hardware, etc) worked except for internet access, which I couldn't get working at all. Internet access worked under Linux, so I ended up putting a live install of Linux Mint on an SD card, and allowing him to boot via Plop to Windows 7 for gaming, or Linux for Internet access. Not ideal, but he was happy.

I should mention that I couldn't boot from the SD card on that netbook using the ESC > F9 menu (which takes you to the Boot menu, to choose which device to boot from), as no option to boot from the SD card appeared, which is why I went looking for a software solution, and found the very handy Plop, which does the job very well, thanks.

Anyway, a couple of days back I thought I'd try Linux myself, and since all three USB ports on my laptop are taken up (a mouse, external USB keyboard, and as a connection to the laptop cooler) I thought I'd put the live version on a (32MB) SD card I had spare, but it turns out that the laptop (HP G6 1331) won't boot from the SD card, even though it's an option in the BIOS > Boot Order setup. And like my nephew's netbook, when, first booting, you press F9 to choose a boot device, the laptop seems to scan it's ports and only list things it can boot up from, so F9 doesn't list the SD card as a bootable option (neither does my nephew's netbook, but using Plop it can be booted from the SD Card).

So I thought "No problem, just install Plop", and I have, but Plop won't boot the Linux install. I ended up taking the laptop to my nephew's house, and trying his SD card in my laptop (it boots) and my SD card in his netbook (it boots). But neither SD card will boot in my laptop (the G6 1331). It's possible I am installing Plop wrongly on my laptop, or not doing something that I did when I installed Plop on his netbook, but I don't know what.

On my nephew's netbook, when I boot and the

Windows 7
Plop Boot manager

menu appears, I select Plop, then select USB, and Linux boots from the SD card automatically. But when I do the same on my G6 1331 laptop, Plop gives this response;

http://i166.photobucket.com/albums/u90/SilverGromit/G61331-Ploperror_zpsf4089c43.jpg

The SD card does read on the laptop in Windows, so it's not the SD card port that's at fault (at least I suppose not - could the port be faulty and stop the laptop from booting up, but still be healthy enough to allow the laptop to read from the SD card in Windows?). By the way, the laptop is running Windows 7 64bit, as is my nephew's netbook, and both are Hewlett Packard machines, both bought new within the last year or two, and both have the same sort of idiot's BIOS (i.e. almost no options that you can change), and both only list the options that you can boot from there and then, when you select the Boot Device via F9 (i.e. if there is a bootable USB stick then it's listed, but if not (if there's no USB stick inserted, or if there is but it's not bootable) then there's no option on screen to boot from the USB stick.

I'm completely new to Linux, and know nothing about it, by the way, so please don't assume any level of Linux knowledge from me. I don't think Linux is relevant here, as both SD cards boot on my nephew's machine, so I imagine nothing more needs to be done to either card to get it to boot on my laptop, but maybe there is, I don't know.

Thanks for any replies.