HELP !!! Please........

Started by Azoic, July 05, 2015, 15:10:01 PM

Previous topic - Next topic


Having installed PLOP, i rebooted the machine, and tried to do what i installed it for, which is to boot from SD Card, from the card inbuilt reader, it didn't seem to work, but i didn't want to give up, so i thought i would try looking at the installed files, to see if i could see why, but, now, i can't boot into the installed system on the HDD.
Grub was working, i added PLOP via the linux install guide, and it seemed to run fine, but selecting hda1 in the boot menu, it shows id82 x 2 and the id83 swap partitions, but selecting either hda1 or hda2 in the PLOP menu brings a black screen and cursor. Neither BOOTABLE partition seems to be the ACTIVE one anymore.....

I assume i need to reinstall grub ?? or alter it someway to allow the redirect from the PLOP menu to find the OS install. Only question i have is HOW DO I DO THAT ???
I set the PLOP menu to hidden and now i have no boot selection menu except devices, FDD,CD/DVD,HDD,LAN or into setup. This laptop has no floppy, and has NO setting in the BIOS to boot from USB. If i use an external USB FDD or CD/DVD it adds a USB option in the BIOS. If i let it run a normal boot, it comes to the PLOP menu, but selecting HDD it hangs.

Can someone guide me on the fix, i was sure i found this issue here somewhere BEFORE i crunched my laptop, but i can't find that post anywhere might have been on another site, to fix another issue though, as i followed some links in posts here, and these went all over the place including the it might have been a similar issue,  that had the blank screen, but isn't related to PLOP.

Any help here would be greatly appreciated.


Using Boot-Repair-Disk, i managed to get back to my desktop, but this is an incorrect fix, the PLOP installer is still showing in the grub menu, now at INSTALL stage, if i run it again, i assume i will get the same result, an UNBOOTABLE OS, can anyone give an idea of what i should be doing to fix it correctly?
I know the bootloader works, its running fine on windows 7 and a vista machine, but this debian is giving me a headache.
IT HAS TO BE A SYNTAX error during the install, and i assume it is MY FAULT, as the software is exceptionally well done, and  work's seemlessly in a windows machine. Elmar has done an INCREDIBLE job, and made a difficult task as easy as he could. BLOODY GOOD EFFORT i say, now if only i could get the damn thing working correctly on my hardware............i know it will work, we just have to find the solution.

:) :) Please Help. :) :)



i can tell you what happened. Grub is your boot manager installed in the MBR. Grub starts on your computer Linux and maybe other OS to. You started the Plop Boot Manager install program from Grub. This installs the Plop Boot Manager to the MBR (where currently Grub lives). Now, when you start your computer, the Plop Boot Manager comes up. You cannot boot Linux anymore. Why? Because the Plop Boot Manager can boot only boot sectors. But on your Linux partition is Grub not installed in the boot sector. -> Booting fails.

Solution 1: If you want the Plop Boot Manager in the MBR, then you have to install Grub to the boot sector of your linux partition.
Solution 2: You keep Grub in the MBR and do not install the Plop Boot Manager to the MBR. Just start the Plop Boot Manager from the Grub menu with using plpbt.bin instead of in your Grub config.

Best regards


Hi Elmar,

Thanks for the reply, it never occured to me that grub would be essentially overwritten by your manager. I usually just do an MBR install of grub, as i don't dual boot, if i need a windows machine, i switch HDD in the laptop. Saves a format and re-install and no worry of lack of space on a i didn't even think that grub was not being looked for bad.

I will see if i can get it going now, i don't think it is going to do what i wanted anyway, but that's due to my hardware, NOT your software.

Thanks again for the reply, i know your time is precious.