Author Topic: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".  (Read 32951 times)

johnhc

  • Newbie
  • *
  • Posts: 22
plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« on: January 02, 2012, 17:59:20 PM »
I have used plpbt.iso for some time on my VM (VMware Player) with no problems.  I burned the iso to a CD and booted into my new HW and it hung after the header message ending in "Loading plpbt.bin...ready".  Only the Ctl-Alt-Del keys seem to work.  My new HW is an ASRock 990FX Professional with a UEFI BIOS (latest 1.50).  I have no USB flash sticks plugged, but do have a wireless mouse which uses a USB (2.0) dongle.  Please let me know what other information is needed.  Thanks much for any help.  Enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #1 on: January 02, 2012, 19:30:51 PM »
try the floppy image instead of the iso

regards
elmar

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #2 on: January 02, 2012, 20:09:56 PM »
Thanks for your quick reply, Elmar.  I have booted plopkexec.img floppy image in my VM and it says waiting for a Linux USB stick.  I would like to boot into a prompt like the star field that allows me to select a device to boot from.  I need a way to boot one of several disks/partitions on my machine into Windows.  This is just an emergency measure I am preparing for and what I see in the plpbt.iso on my VM is what I think I need.  I have almost no knowledge of Linux and may not even be booting the correct image.  I see in the [BOOT] folder of the Plop package I DLed an image called Bootable_NoEmulation.img.  Is this what I am to be using?  It is only 2 KB and seems too small.  Thanks again and enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #3 on: January 02, 2012, 20:14:31 PM »
i dont mean plopkexec. you have to use the plpbt.img

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #4 on: January 02, 2012, 22:08:23 PM »
Thanks again, elmar.  I am showing my ignorance now.  I tried to burn the plpbt.img  to a DVD using ImgBurn and Windows (W7 x64).  Both said it was not a valid disc image.  I connected it to my VM as a floppy and it booted just fine and shows the star field.  I do not have a floppy drive on this machine.  I can see the files on the VM system.  Can I copy these files onto a bootable flash drive?  Can you point me to a explanation of how to do this.  I have made USB sticks to boot DOS and WinPE but never with an .img file.  Thanks and enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #5 on: January 03, 2012, 05:34:40 AM »
I tried to burn the plpbt.img  to a DVD using ImgBurn and Windows (W7 x64).  Both said it was not a valid disc image. 

yes, because a floppy image is for floppies. and iso images are for cd/dvd's

I connected it to my VM as a floppy and it booted just fine and shows the star field. 

thats the correct use for the vm

I do not have a floppy drive on this machine.  I can see the files on the VM system.  Can I copy these files onto a bootable flash drive?  Can you point me to a explanation of how to do this.  I have made USB sticks to boot DOS and WinPE but never with an .img file.  Thanks and enjoy, John.

i dont know if i understand you correct. you want to start the boot manager from usb, correct?
do you want to start an operating system from that usb drive too?

everything is possible, but the high flexibility of my tool makes it difficult give an answer that covers all solutions, so i need those details.

regards
elmar

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #6 on: January 03, 2012, 17:59:43 PM »
Thanks so much for your time.  I really appreciate it.  My system has a PCIe based OCZ SSD and an onboard (AMD) based RAID5.  My system is installed on the SSD and the RAID5 contains data including W7 installation files.  The OCZ forum recommends that all drives be removed from the system except the SSD when doing system install.  Many posters have problems installing Windows.  I suspect that Windows setup is getting lost in the middle and not restarting to the correct partition.  In my prior system I did all my installs from a flat.  I started setup from another partition running XP (will WinPE now)with all the install files stored on a data partition.  This (coupled with an almost completely unattended installation of all my applications) allowed me to do often installs and needing only about a hour total time.  I would at least like to try a flat install since I upgraded to the SSD.  If setup gets lost during the process, as a backup plan, I would like to boot Plop and try booting partitions until setup starts running again.  May be a pipe dream but I at least want to try it.  My ultimate backup is a USB stick with all my install files.
I had tried to put Plot on a 512 KB flash stick and it would not boot.  I suspect this is my HW because I also tried WinPE boot from a 512 KB stick and it also fails to boot.  I bought a couple of 2 GB sticks yesterday.  WinPE boots fine from one and Plop boots to the message: "Remove disk or other media.  Press any key to restart..........".  When I press a key, Windows boots.  I have tried removing my USB mouse dongle with no help.
Thanks much for your help.  Enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #7 on: January 03, 2012, 18:28:30 PM »
WinPE boots fine from one and Plop boots to the message: "Remove disk or other media.  Press any key to restart..........".  When I press a key, Windows boots.

did you only copy the plop boot manager files to the usb drive? or have you done anything else?

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #8 on: January 03, 2012, 19:42:48 PM »
elmar, I have attached a screen shot of the files/folder I copied to the USB stick.  When I mounted it just now to look, the stick was empty.  I will recreate it, try again and update this post.  Thanks and enjoy, John.

EDIT: I get the same result with my remade USB stick and it is not empty when I boot back into Windows.  Here is the preparation I use:

Diskpart
list disk
select disk #                                    # being the USB stick!
detail disk                                        Make sure you have selected the correct disk!
clean
create partition primary
select partition 1
active
format fs=fat32
assign
exit
« Last Edit: January 03, 2012, 20:08:45 PM by johnhc »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #9 on: January 03, 2012, 20:07:08 PM »
you cannot simply copy files to the usb drive and hope that it boots. that cannot work.

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #10 on: January 03, 2012, 20:10:55 PM »
elmar, OK, how do I do it?  This is the procedure I use with WinPE and it works fine.  Please see my EDIT in my previous post.  Thanks and enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #11 on: January 03, 2012, 20:18:06 PM »
in your case, the easiest is to rename isolinux.cfg to syslinux.cfg and run the program syslinux.exe [usb drive letter:]
when you do not edit syslinux.cfg then the files syslinux.cfg and plpbt.bin must be in the root directory of your usb drive.

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #12 on: January 03, 2012, 20:23:21 PM »
Thanks, I will give it a go.  I have found the instructions for doing this on the Plop site, but will use your recommendation.  I obviously assumed too much - that Plop onto a USB would be the same as WinPE.  Stupid mistake in hindsight.  Thanks and enjoy, John.

EDIT: I am back to the same problem with the same message (thread title) as I started with except with USB stick instead of CD.  What can I do to make some progress?  Thanks and enjoy, John.
« Last Edit: January 03, 2012, 20:40:57 PM by johnhc »

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #13 on: January 03, 2012, 22:04:11 PM »
elmar, I am back where the thread started.  Please see my Edit in the last post.  Suggestions?  Thanks and enjoy, John.

EDIT: Tried my stick on VM and it worked fine.
« Last Edit: January 03, 2012, 22:18:26 PM by johnhc »

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #14 on: January 05, 2012, 14:57:22 PM »
elmar, I am still hung at "Loading plpbt.bin...ready".  Is there no hope of getting to the boot manager menu and star field on my HW?  Suggestions, please.  Thanks and enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #15 on: January 05, 2012, 17:22:49 PM »
i will release a small tool to fix that problem

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #16 on: January 05, 2012, 17:33:49 PM »
Great, thanks Elmar!  I look forward to testing it.  Enjoy, John.

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #17 on: January 16, 2012, 22:02:27 PM »
i will release a small tool to fix that problem
Elmar, I would like to try a flat install soon but would like to have Plop BM as a backup.  Have I missed your release of the 'small tool'?  If not, can I expect it soon?  Thanks much and enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #18 on: January 17, 2012, 08:46:12 AM »
hi,
i was so busy, i forgot the tool. i plan to release a new boot manager version. i hope i can do all the work this weekend. the tools will come with the new release. but i cannot promise it.

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #19 on: January 17, 2012, 17:20:32 PM »
OK, Elmar thanks.  If I can test for you, please let me know.  Enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #20 on: January 17, 2012, 17:26:38 PM »
it will be installed on a fat32 partition, or?

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #21 on: January 17, 2012, 17:53:57 PM »
it will be installed on a fat32 partition, or?
Elmar, I currently have it installed on a FAT32 partition on a USB stick.  Thanks and enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #22 on: February 01, 2012, 19:59:53 PM »
it will be installed on a fat32 partition, or?
Elmar, I currently have it installed on a FAT32 partition on a USB stick.  Thanks and enjoy, John.

are you ready for a test?

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #23 on: February 01, 2012, 20:11:28 PM »
Quote
are you ready for a test?
Elmar, I am.  I should point out that I did a flat install this morning with no problems.  I am still interested in having a BM that can I boot into my HW.  Thanks and enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #24 on: February 01, 2012, 20:20:18 PM »
I should point out that I did a flat install this morning with no problems.

does that mean you do not get the "Loading plpbt.bin" hang although you have the same setup?

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #25 on: February 01, 2012, 20:33:11 PM »
I should point out that I did a flat install this morning with no problems.

does that mean you do not get the "Loading plpbt.bin" hang although you have the same setup?
Elmar, no, I still get the hang.  If you will look at my earlier post, I was hoping to use Plop BM as a backup in case Windows Setup failed to boot the correct partition during a flat install.  I still cannot boot Plop BM on my HW.  It still hangs as in the title of this thread (hangs "Loading plpbt.bin").  Enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #26 on: February 01, 2012, 20:43:27 PM »
ok, i was no sure because of
I should point out that I did a flat install this morning with no problems.

the install could be anything. however, now its clear.

i will give you tomorrow a test version. you get the instructions via email (thats a faster communication). it will be a test version, please be sure that you have a backup of the data on the usb drive.

regards
elmar

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #27 on: February 01, 2012, 20:47:41 PM »
Elmar, OK, thanks.  I assume this will be no danger to the data on my drives.  Enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #28 on: February 02, 2012, 13:55:05 PM »
btw. was there any reason why you did not install the plop boot manager to the mbr of the usb drive?

i am testing the tool, so you get a version shortly

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #29 on: February 02, 2012, 14:50:38 PM »
btw. was there any reason why you did not install the plop boot manager to the mbr of the usb drive?
Elmar, I have only USB sticks (flash) and no HDDs.  I would not know what it means to install Plop BM to the MBR of a flash drive.  Enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #30 on: February 02, 2012, 15:36:34 PM »
Elmar, I have only USB sticks (flash) and no HDDs.  I would not know what it means to install Plop BM to the MBR of a flash drive.  Enjoy, John.

usb flash drives have the exact same layout like a hard disk. they have a mbr with a partition table and partitions. mostly only one, but you can create primary and logical partitions on a flash drive too.

i dont know if you only want start the plop boot manager or if you want boot also something else from the usb drive.

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #31 on: February 02, 2012, 15:49:42 PM »
i dont know if you only want start the plop boot manager or if you want boot also something else from the usb drive.
Elmar, I want to be able to boot the boot manager to the star field option menu and boot other sources from there.  Please see post #18 in this thread.  Enjoy, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #32 on: February 02, 2012, 16:01:13 PM »
Elmar, I want to be able to boot the boot manager to the star field option menu and boot other sources from there.  Please see post #18 in this thread.  Enjoy, John.

i cannot see anything that you said that you want to have both. however, there are only 2 solutions to start the plop boot manager + something else from the usb drive
1) install the plop boot manager to the mbr of the usb drive
2) use another boot manager like grub or grub4dos and start plpbt.bin as option of the other boot manager.

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #33 on: February 02, 2012, 16:09:21 PM »
Elmar, I am not interesting is learning another application (Grub, etc).  I have already looked at that.  What I am really trying to do is to be able to boot Plop BM to the same point I can in a VM (VMware Player).  I want to eliminate the hang of the title of this thread.  If installing Plop BM to the MBR of the USB stick does this then OK - tell me how to do that.  Thanks, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #34 on: February 02, 2012, 16:14:38 PM »
start the installer
http://www.plop.at/en/bootmanager.html#installhd

in the install program select the usb drive with option 7 and then install the boot manager with option 1


johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #35 on: February 02, 2012, 21:13:28 PM »
Deleted
« Last Edit: February 06, 2012, 19:57:22 PM by johnhc »

johnhc

  • Newbie
  • *
  • Posts: 22
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #36 on: February 07, 2012, 20:23:05 PM »
Elmar, I tried the 5.0.14 version of Plop BM and it hangs the same.  I am not sure it was supposed to correct the problem but one fix in the release notes sounded like my hang.  Thanks, John.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: plpbt.iso boot hangs at :"Loading plpbt.bin...ready".
« Reply #37 on: February 07, 2012, 20:49:31 PM »
Elmar, I tried the 5.0.14 version of Plop BM and it hangs the same.  I am not sure it was supposed to correct the problem but one fix in the release notes sounded like my hang.  Thanks, John.

the fixes are not related to your problem

it does not work, because you use the same way that not works on your pc. regardless to the hang, the way that you used is wrong because you want to boot beside the boot manager also another os from usb. so you have to install the boot manager to the mbr
i restructured the documentation, but the infos are the same like at the link above
http://www.plop.at/en/bootmanager/mbrinstall.html
choose a method, select in the installer the usb drive as destination disk and install the boot manager
« Last Edit: February 07, 2012, 20:51:39 PM by Elmar »