Author Topic: Plop Linux PXE -> NFS does not mount, Error "mount.nfs: Protocol not supported"  (Read 3019 times)

The_Raven

  • Newbie
  • *
  • Posts: 14
Hello

I try to load Plop over PXE. It starts normally but then it can not mount the NFS-Share.
It shows "mount.nfs: Protocol not supported".
Then i have tried to mount it on the busybox-console. Same error.
I have also tried with options "vers=3" and "nfsvers=3" but without success.  :(
If i mount this share from a LinuxMint client it is working fine.
The only parameter i use is "nolock". This seems to be mandatory.

Any idea why the "protocol" is not supported?  :-\
Is only NFSv4 supported by plop?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
Hello,

NFSv3 and v4 is supported. What OS do you use as server? Maybe I can reproduce the problem.

Elmar

The_Raven

  • Newbie
  • *
  • Posts: 14
Maybe this is the "problem". Server is a (very old!) opensuse 10.2.
Unfortunately i can not update this server.  :(
I have also checked the log from the server, but i don't find anything interesting.
Yesterday i tested it with another (temporary) test-server (linux mint 17.2) and with this it has worked!
So it must be a combination of client and server that causes this problem.
Opensuse-Server has kernel "2.6.18.2-34-default" (brrr, very old). I don't know how to find the version of the installed nfs-server. The version of "nfsstat" is 1.0.10.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
What happens when you try to mount the share from a Plop Linux booted from USB or DVD?

The_Raven

  • Newbie
  • *
  • Posts: 14
Good idea!
This works!  :o
If i run it with "-v" i see that it tries first to mount with vers=4. But this does not work, error "Operation not permitted" (don't know why), then it switches to vers=3 and this is working.

So now the question:
Why is it working if plop is bootet but not during the boot process?  :o

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
Please post the full output of -v

The_Raven

  • Newbie
  • *
  • Posts: 14
From the working (bootet from usb) or from the non working (pxe)?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
If possible from both.

A smartphone photo would be good enough.

The_Raven

  • Newbie
  • *
  • Posts: 14
Ok, here they are.
As you can see, the option "nolock" is mandatory.
The only difference i see is "protocol not supported".
Hope you have an idea.
Looks still strange to me!  :o

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
Are you able to ping the PXE server in the busybox shell?

The_Raven

  • Newbie
  • *
  • Posts: 14
Yes, ping works but mount not (tested again).
And, if i change the NFS-Server to another host (test-system) the mount works.
So it must be the combination of "busybox" and "nfs-server" from opensuse.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
Busybox is not the problem. Next week i finalize everything for the new Plop Linux release. I will also try to reproduce the problem. Maybe I can fix it easily for the new version.

The_Raven

  • Newbie
  • *
  • Posts: 14
Sounds good, hope you find a solution.
If you need any help, just let me know (if i can help...).  :)

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
hello,

can you try the test version? ~670MB, it comes without opt.sqfs
https://download.plop.at/tmp/ploplinux-4.3.1-x86_64-raven.tar.gz

Regards
Elmar

The_Raven

  • Newbie
  • *
  • Posts: 14
Yes, but it takes a little bit. Not much time ATM.   :(

Edit: Tested but same error "protocol not supported".  :(
« Last Edit: November 27, 2015, 11:05:14 AM by The_Raven »

alexo

  • Newbie
  • *
  • Posts: 2
Hello,
I'm facing the same issues.
When I try to boot the latest plop linux version over NFS it fails to auto mount it.
But at the busybox shell I can mount with   mount.ntfs -o nolock,nfsvers=4  xxxxxx /media
It mounts just fine and then when I exit the busybox shell,  Plop resumes fine.

The question is:
How to pass the nolock and the nfsvers=4 options to the llinux kerner during boot?
I have tried with nfrsroot=xxxxxxx,nolock,nfsvers4  in my pxe config files but it doesn't work  :(

Thank you!

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2353
  • a command shell is enough to do amazing things
Hello,

Hello,
The question is:
How to pass the nolock and the nfsvers=4 options to the llinux kerner during boot?
I have tried with nfrsroot=xxxxxxx,nolock,nfsvers4  in my pxe config files but it doesn't work  :(

see this example how to add parameters. You add it after a pipe |

Example: nfsmount=10.0.0.1:/tftpboot/ploplinux-netboot|rsize=2048,wsize=2048,nolock,vers=2,hard,intr

Regards
Elmar

alexo

  • Newbie
  • *
  • Posts: 2
Thanks, it works now. I thought I need to use comma and not pipe. Thanks again.