Author Topic: plpbt.bin file not found (Solved)  (Read 6691 times)

Brotherred

  • Newbie
  • *
  • Posts: 20
plpbt.bin file not found (Solved)
« on: April 23, 2016, 05:25:49 AM »
Ok sorry for making a new thread. It seemed like the thing todo after a reformat/ reinstall. Anyway below is all the details of my plpbt configuration. Now instead of getting partition not found I am getting file not found. I have been attempting to follow https://www.plop.at/en/bootmanager/plpbt.bin.html#rungrub2
The forum post at https://forum.plop.at/index.php/topic,1456.msg6310.html#msg6310 was also a lot of help. But I do have plpbt.bin in /boot. My /boot is
Code: [Select]
/dev/sda9 What can am I doing wrong with this? I have also attached a picture of my plpbt error. Oh and perhaps it is clear but I have run update-grub2 and out of superstition I also did update-grub.

Code: [Select]
#exec tail -n +3 $0
menuentry "Plop Boot Manager" {
    set root=(hd0,9)
    linux16 /boot/plpbt.bin
}


ls /boot
abi-3.16.0-37-generic         memtest86+.bin
abi-3.16.0-70-generic         memtest86+.elf
config-3.16.0-37-generic      memtest86+_multiboot.bin
config-3.16.0-70-generic      plpbt.bin
grub                          System.map-3.16.0-37-generic
initrd.img-3.16.0-37-generic  System.map-3.16.0-70-generic
initrd.img-3.16.0-70-generic  vmlinuz-3.16.0-37-generic
lost+found                    vmlinuz-3.16.0-70-generic

# /boot was on /dev/sda9 during installation

It is all so irritatingly simple especially having it explained so many times yet strangely difficult like nothing I have ever tried to do. Regards
« Last Edit: April 23, 2016, 22:57:07 PM by Brotherred »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: plpbt.bin file not found
« Reply #1 on: April 23, 2016, 11:16:13 AM »
Hello,

you are using a partition as boot partition which will be mounted by the os to /boot. When you save plpbt.bin to /boot/plpbt.bin then the file is saved in the root directory of the boot partition. Grub is running before the os. So there are no partitions mounted when grub is running. Grub access the partition directly. That means the full path of plpbt.bin on the partition is /plpbt.bin

You have to change the linux16 line. The correct configuration in the grub config is
Code: [Select]
linux16 /plpbt.bin
Best regards
Elmar

Brotherred

  • Newbie
  • *
  • Posts: 20
Re: plpbt.bin file not found
« Reply #2 on: April 23, 2016, 22:56:26 PM »
Perfect. The star field never looked so good!


Thanx, regards.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: plpbt.bin file not found (Solved)
« Reply #3 on: April 23, 2016, 23:02:11 PM »
yippee :)