Author Topic: NO VALID BOOTSECTOR SIGNATURE  (Read 6222 times)

malko

  • Newbie
  • *
  • Posts: 4
NO VALID BOOTSECTOR SIGNATURE
« on: May 12, 2016, 12:42:40 PM »
Hello,

I have read many pages of this forum but did not see something to help me.
If this issue has already been answered, thanks to redirect me with a link  :)


After playing a while with a linux distro (AmiPUP 1.1.3), I decided to add it to my laptop.
The laptop already runs plop 5.0.15 (MBR) and Win7 (/dev/sda2).

According to GParted, partitions are as follow :
  /dev/sda1 : laptop diag partition
  /dev/sda2 : ntfs - win7
  /dev/sda3 : extended
  /dev/sda5 : ntfs - win7 swap
  /dev/sda6 : ext2 - AmiPUP
  unallocated
  /dev/sda7 : ntfs - win7 new laptop drivers

According to the "Puppy Universal Installer", the installation of AmiPUP went successful (/dev/sda6).
According to the "Grub4Dos boot-loader config", the installation of Grub4Dos went successful on the "Partition Boot Sector" (PBS) of /dev/sda6 ("Do not rewrite the existing boot record" box ticked).

After reboot, on plop menu, I have added a new AmiPUP profile and linked the third line on the "linked partition" menu.
So the third line of "HDA" is now : *80H  DON'T TOUCH  L2.
To my understanding the second extended partition is referred by plop as L2 (which is on Grub: /dev/sda6).

I am expecting the following actions :
Turn on PC -> MBR (plop) -> /dev/sda6 (Grub4Dos) -> AmiPUP

And now, why I wrote all those lines :D

When I try to boot AmiPUP, the following message is displayed on the screen :

LOAD PROFILE DATA
MBR: CHECK
MBR: IS VALID
CHECKING BOOTSECTOR

WARNING:
NO VALID BOOTSECTOR SIGNATURE
CONTINUE BOOT? [Y/N]


By pressing "Y", screen gets black and cursor blinks on the top left corner of the screen.
and nothing...

I have tried with L1 (NTDRL missing error message), L3 and L4 (same NO VALID BOOTSECTOR message), but nothing helped.

Does anybody have an idea on how to get Grub4Dos loaded ?
Did I miss something ?

Thanks in advance.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: NO VALID BOOTSECTOR SIGNATURE
« Reply #1 on: May 12, 2016, 13:14:56 PM »
Hello,

So the third line of "HDA" is now : *80H  DON'T TOUCH  L2.
To my understanding the second extended partition is referred by plop as L2 (which is on Grub: /dev/sda6).

You understood it correct, but modern partition programs are creating cascaded extended partitions which are not supported by the Plop Boot Manager 5.x series. The solution for your problem would be to

- either install grub/grub4dos to the boot sector of sda5
- or install AmiPUP to sda5

then use L1 on the third line of HDA to boot the partition.

Best regards
Elmar

malko

  • Newbie
  • *
  • Posts: 4
Re: NO VALID BOOTSECTOR SIGNATURE
« Reply #2 on: May 12, 2016, 14:12:02 PM »
Hello Elmar,

Thanks for your quick answer  :)

Quote
You understood it correct, but modern partition programs are creating cascaded extended partitions which are not supported by the Plop Boot Manager 5.x series. The solution for your problem would be to

- either install grub/grub4dos to the boot sector of sda5
- or install AmiPUP to sda5

then use L1 on the third line of HDA to boot the partition.

I will give a try to your first recommendation and tell you back.

Best regards

PS: Thank you for programming such a good tool.