Author Topic: Upgrade Firefox Steps  (Read 2638 times)

fritual

  • Jr. Member
  • **
  • Posts: 60
Upgrade Firefox Steps
« on: June 30, 2016, 18:59:56 PM »
Hi,
Firefox 43.0.1 bundled w/Plop Linux reports it's old and needs updating.
Firefox pre-compiled binary files:

https://support.mozilla.org/en-US/kb/install-firefox-linux

Firefox dependencies:

https://www.mozilla.org/en-US/firefox/47.0.1/system-requirements/

Q: Is there a tried-and-true HowTo?
thx
fritual


Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Upgrade Firefox Steps
« Reply #1 on: July 01, 2016, 14:00:04 PM »
I assume, you mean for the Live Plop Linux.


Download Firefox for Linux (32bit or 64bit depending on what you need) from https://www.mozilla.org/en-US/firefox/all/
Extract the archive.

You have to uncompress the file ploplinux/opt.sqfs

unsquashfs opt.sqfs

Change to the directory 'squashfs-root' and remove the 'firefox' directory.
Copy the extracted 'firefox' directory from the downloaded Firefox archive to the 'squashfs-root' directory.

Remove the old 'opt.qfs'.

Compress the 'squashfs-root' directory.

squashfs squashfs-root opt.sqfs


Best regards
Elmar

fritual

  • Jr. Member
  • **
  • Posts: 60
Re: Upgrade Firefox Steps
« Reply #2 on: July 02, 2016, 05:15:58 AM »
I assume, you mean for the Live Plop Linux.


Download Firefox for Linux (32bit or 64bit depending on what you need) from https://www.mozilla.org/en-US/firefox/all/
Extract the archive.


Best regards
Elmar
Elmar,
Live Plop Linux is correct.  Flash is not part of the firefox binary and must be downloaded from Adobe:

https://get.adobe.com/flashplayer/


Suspect Plop Linux requires the Flash 11.2 for linux (tar.gz) 32-bit version.
Q: How's Flash installed correctly to get it to interface with firefox?
thx
fritual

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Upgrade Firefox Steps
« Reply #3 on: July 02, 2016, 12:07:45 PM »
Suspect Plop Linux requires the Flash 11.2 for linux (tar.gz) 32-bit version.
Q: How's Flash installed correctly to get it to interface with firefox?

See https://www.plop.at/en/ploplinux/live/faq.html number 20.