Author Topic: PLoP fails to load CDROM driver  (Read 6073 times)

briansrapier

  • Newbie
  • *
  • Posts: 2
PLoP fails to load CDROM driver
« on: March 10, 2010, 16:41:03 PM »
Greetings. I have an "older" Dell laptop (Latitude LM, 133MHz, 40 MB RAM, 2 GB HDD) that has a stale/corrupted version of W2K installed (will only boot in safe mode, otherwise it locks up and crashes). I basically just want to install Puppy or Knoppix, but the BIOS does not support booting from the CDROM. Additionally, it doesn't have a floppy, so my options are limited.

I originally attempted to install SMB within safe mode, but kept getting a "failed read/write error". I had better success getting PLoP to run from the Windows boot menu. However, when I select "CDROM" from the menu, I get a variety of errors. The first error is usually:
Quote
LOADING CDROM DRIVER
CD-ROM CDR_N110
WAITING FOR THE DRIVE...
CD NOT BOOTABLE

If I hit <ESC> to return to the main menu and attempt the boot again, even with new media, I get:
Quote
LOADING CDROM DRIVER
NO CDROM FOUND

The media is bootable, verified on other machines, and the CDROM is working as I have used it to load tools on the machine.

My assumption is that the driver built into plpbtldr.bin is incompatible with my drive. Is there a method to load other drivers (i.e., OAKCDROM.SYS) that Windows normally uses?

BTW, I'm using the instructions here to deploy PLoP.

Thanks.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: PLoP fails to load CDROM driver
« Reply #1 on: March 10, 2010, 17:11:39 PM »
hi,
loading another cdrom driver is not possible.

what happened when you insert the cd when plop is started and then try to boot the cd. or start the dell when the cd is inserted and try to boot the cd. i mean, try some variations. i know this is no good solution, but maybe you have luck and one way works. there are some ide cd drives where the driver is not working correct. according your description, the driver is able to read some sectors the first time, but then it does not detect that the cd is bootable. i don't know why. in vmware its the same. if i fix it for vmware, maybe its fixed on your dell to.

regards
elmar

briansrapier

  • Newbie
  • *
  • Posts: 2
Re: PLoP fails to load CDROM driver
« Reply #2 on: March 10, 2010, 17:29:42 PM »
Ha! So simple, yet that worked!

When the boot menu came up, I simply selected cdrom, then closed the drive bay. After a few seconds, it booted!

Cool!

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: PLoP fails to load CDROM driver
« Reply #3 on: March 10, 2010, 17:45:42 PM »
cool  ;D