How to boot linux partitions on external USB HDD

Started by adamjr, May 29, 2018, 14:02:59 PM

Previous topic - Next topic


I am trying to boot my external USB HDD, but I tried Plop Boot Manager and PlopKexec and both seem to detect the device but not find the partitions?
The error message is "No HD", (both EHCI and UHCI)
When I put the HDD inside the laptop instead of in the USB case I can still use it.
I can read all the data on the USB HDD with debian (I didn't try mounting the device with the Plop live, should I do that?)
Thanks for writing by the way.  Your work is a positive contribution to the world.

Numbers 1 and 3 are linux root partitions:
Model: Initio ST9500420AS (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type      File system     Flags
3      38.2GB  96.4GB  58.2GB  extended                  lba
5      53.2GB  96.4GB  43.2GB  logical   ext4
1      96.4GB  182GB   85.9GB  primary   ext4            boot
2      182GB   187GB   4293MB  primary   linux-swap(v1)
4      187GB   500GB   314GB   primary   ext4


I assume, its a standard hard disk installation and not a live installation on your USB hard disk.

Plop Boot Manager: The problem is, that your computer seems to use an internal USB hub, witch is not supported by the 5.x release.

Plopkexec: I assume, you use grub2 as boot manager on the USB drive. grub2 config files are not well supported by plopkexec. You should create a custom plopkexec.cfg file with kernel and initrd configuration in syslinux format.

Best regards


Great! Fixed.
I connected to a USB port that was not on a hub and it worked! (using Plop boot manager).
Thanks Elmar!