General Category > Boot Managers

Noob questions: plopkexec entry for grub2 AND/OR running plopkexec with kexec

<< < (3/3)

Supposedly there is a "--reuse-video-type" but I have no idea where I am supposed to add that (I only see it as a recent change in git log).

Also I see "--reset-vga" which just doesn't seem to work. So far the only thing that returns a visible output is grub.exe as I told you before, but it seems maybe kernels and even plopkexec starts just it is not visible what I am doing.

What I experience is rerally similar to this error:

Early KMS might not help in my case because my intention is actually to run a really old (2.6) kernel from a secondary SD card in my machine so I doubt I can add an early KMS to that old kernel... Also I don't see much value in adding an early KMS into plopkexec generally because it seems wrong to put in all the drivers for every possible card :-). Also I kind of feel that when I ran plopexec from grub and mounted a system just to kexec it manually from the terminal thing froze the same way so ah..... this is just a bit complicated...

I have a Mobility radeon 200M card using the open source radeon driver and KMS enabled on arch linux.

PS.: Maybe I will go back to the "grub.exe" approach as for some random reason it not only starts up, but actually I can see what I am writing. I do not know how they are able to do so though...

Beside plopkexec:

--- Quote from: prenex on May 18, 2019, 21:58:11 PM ---I have a laptop that cannot boot from its internal SD card reader and now has an archlinux32 installation that is fast for all things except gaming as it seems the latest drivers dropped 3D performance by 50-100%... Earlier I had an ubuntu 16.04 with good-enough 3D but it is always best to update the system or make it more light. I have failed miserably with updating to 18.04 as they tend to not test stuff as 32 bit is not supported anymore so I changed to arch32 just to find out that despite there is 3D acceleration it is too slow. Then came an idea: why don't just install a really old kernel and a really old system for which I have fglrx driver - just for playing and 3D work - and keep the original system as-is if the open drivers slowed down?

--- End quote ---

I am wondering about the performance drop. Have you tried to install the latest driver from the AMD website instead of the repository driver?

The performance drop is from 50-100% using the open drivers. Before it was playable but had glitches with rome 1 total war making it unplayable so the old fglrx might help with this too.

The latest driver from áti website is catalyst 9.2 for my card. No newer catalyst support it anymore and i had to hunt its package from a russian mirror as ati does removed it from the page.

Btw i have a long debugging i have documented on phoronix forums and concluded the slowdown is coming from mesa or x update and not kernel modules. I can link if you are interested. These days i am trying to apply reverts to mesa code according profiler outputs...

For this reason i put kexecing aside a bit. Also ubuntu 8.04 does not boot from usb on my laptop if i install it on an other machine so i might need to install it on the laptop (or install an old arch maybe). Arch has nice repo archives so that might help me later. That is how i downgraded mesa+x too...

So the drop is between the old open and new open driver, but the closer one is only available for an ancient 2.x kernel and hanga with newer. That is why i wanted to have an old system to the side even if i get back the good performance with the new open mesa after patched there might be glitches that the old closer driver handles better...

Closer -> closed source


[0] Message Index

[*] Previous page

Go to full version