Frustrated unable to boot windowsXP or 2003 setup from prepared USB media

Started by michiganbroadband, April 14, 2010, 17:19:42 PM

Previous topic - Next topic


I've spent several days trying to get this to work..
Would like to boot windows CD image/media from USB since the
computers being used only have a floppy and HDD.

One thing that confuses me while reading through the forum is that apparently
people are using thumb/flash USB drives (which I tried first) it starts to boot
but just goes to a black screen and hangs each time..
Same with usb 1.1 set.

Okay well after reading the entire website  noticed that section 12.
says "Only USB mass storage devices are supported. The USB support allows to boot from usb harddisk, usb sticks and usb cardreaders. USB floppys and CD/DVD drives are not working. "

Great.. no problem that explains why it's not working.. *USB flash/thumb drives don't work*
As is well documented on the site.

OK so I try this all over again with an actual USB/IDE HARD DISK and still does not work but get a black screen whte text that reads "Remove disks or other media. Press any key to restart.

I am using wintoflash software to setup my USB drives from actual Windows setup CDs.. I have also tested that both my usb thumb drives and USB connected HARD disk we are talking about here boot and work properly on another computer that has usb boot support in bios.. have tried PLOP both from Floppy and installed in MBR on the hard drive in the computer. (built-in IDE).  Aam using Latest release PLOP 2010-01-18 as per website download section.

Any help or suggestions are GREATLY appreciated!


I read carefully again.. now I see thumbdrives *are* supported.
Been up for 30+ hours :-) playing.


Quote from: michiganbroadband on April 14, 2010, 17:19:42 PM
OK so I try this all over again with an actual USB/IDE HARD DISK and still does not work but get a black screen whte text that reads "Remove disks or other media. Press any key to restart.

the boot manager cannot write this message, so maybe its from a program started from your usb drive. can you post the mbr and the boot sector from your usb drive? if not, i give wintoflash a try to see where the message comes from.


You are right it's certainly not from plop..
I believe it to be from the bios because I get the same message if I try to boot a non-bootable floppy which in that case it's from the bios..
it's almost asif plop is kicking it back to the bios (where it may have left off)..
since it's not rebooting the HDD and then reloading plop fro the MBR when it happens..
Of course if I reboot the machine.. plop loads back up normally from the hard disk MBR. (I get the normal menu)
Um I'm sure I could get you a copy of the MBR if I knew how... any suggestions?
Do I need to boot a linux floppy and use DD or something to write out the MBR back to the floppy?

Physically getting the hard drive out of this machine is a large task :-)  ..
One reason I'm motivated to get it to work via floppy/USB or even PXE

PXE has it's own story too :-)

I mean I could get the job done by booting dos laoding network drivers over and copying the windows setup files and loading himem yadayadayada (the old fashinoed way) but this would be way better if I could make it work.. and in the future.




Oh silly me... I just remembered plop can 'backup' the current MBR and write it out to floppy :-)
Easy Peasy.


Boot sector posted as backed up by plop full install process :-)
Is this what you were requesting?


I will try this on another computer too..
I believe it not to be working (boot windows2003server setup) from USB flash
on two different computers I have tried... yet the flashdrive boots OK and does a proper windows 2003 server setup from the same flashdrive if booted on a machine that has newer bios that supports boot from usb.


BTW I absolutely LOVE your animated green PLOP at the bottom after install!
Very nice touch! :-)


Quote from: michiganbroadband on April 14, 2010, 20:49:22 PM
BTW I absolutely LOVE your animated green PLOP at the bottom after install!
Very nice touch! :-)


Quote from: michiganbroadband on April 14, 2010, 20:46:16 PM
Boot sector posted as backed up by plop full install process :-)

the problem is that the harddisk where you install the boot manager is stored.

the wintoflash page is down, so i cannot download it


Thanks! I am continuing to try a few things... here's a copy attached of wintoflash that I downloaded two days ago and am trying.
Should you wish to see it.


Yeah Elmar.. wintoflash is not producing a usable usb drive of Windows install cds and the site is down.. hooray ;-)
And the "remove disks or other media" message *is* coming from the usb boot..
Not sure why the other machine gives that message on a faled floppy boot.. but I can come back to that later...

HP also makes a utility but it seems they have locked it down to only accept HP specific CDs/DVD..
It just tells my my wind2003 or XP cd is not a qualifying CD or something like that...

There may be and older version of the HP tool but the one I've been able to find is locked down.
and pretty much useless.


I just completely re-traced my steps and started all over again..

1. made iso drive image from Windows2003 SP1 CD and made sure there were NO read errors in that process. (previous attempt was direct from CD using wintoflash)
2. created a bootable 2GB USB flash thumb drive. (with wintoflash rom my iso)
3. created a bootable 4GB Hard DRive on a USB-IDE adaptor. (with wintoflash from my iso)

Got out 4 laptops two which have USB boot support in bios (details if needed are available)
The other two DEFINITELY DO NOT have any way to boot USB from the bios.
All 4 laptops are 4 different brands & types chipsets/cpus etc.

On both laptops that do not have USB boot support in bios I get these results from 2GB flash drive:
USB2 (default) when commanded to boot the light on the drive flashes one time and just a black screen with a white thin blinking cursor in upper left corner of screen forever.. nothing ever happens after that waited 1 hour. caps lock/ light is still repsonsive.

If I try CTRL+SHIFT+U (usb1) it behaves the same way on screen but I see continuous randomish flashing on the drive (thumb drive led) looks like actual activity but screen never changes in over an hour.. no internal  hard drive activity.

Moving over to the 4GB IDE+USB adaptor Hard drive version I don't get a black screen with cursor but black screen with "Remove disks or other media hit any key to restart" message.

Didn't try/document the ctrl+shift+u attempt on the usb/IDE adaptor hard drive (4GB) yet.

Both USB drives as are work perfectly on the other two laptops that have USB bios boot support.


Thanks for your help Elmar!
Anything you need let me know.. I like work ;-) especially if it accomplishes something!

At this point I'm throughly convinced that the plop+wintoflash combo simply does not work..

I tried another utility that makes usb drives bootable from iso and it works great but it won't make
a working windows setup usbdisk either..
It worked for DSL Linux..
With a windows iso ( using this other utility) it makes a bootable drive but only with a menu called "default" which if selected does nothing...
Seems this other utility is Linux boot disk only (which is progress for me) but still would like to be able to install winXP/2003 from a thumb drive using the plop or other boot manager (which I'm pretty sure does not exist). for older bios'd systems :-)



Seems wintoflash site is still totally down.
I swear I didn't mess with the MBR on that webserver! ;-)
I did attach a two day old copy of the wintoflash software to a previous comment here..
Just in case you wanted to try it.



Haha! no rush...
I've tried off & on for 5 years..
Just got a little more focused these past few days..
Really am curious if it can actually work .. or not. :-)


Do you know if anyone else has actually ever made this work?

I can't help but fundamentally wonder if there is a problem when the boot manager hands it off or loads a dos or windows setup
kernel... that the usb drive and/or port simply stops working..
Although what I have read seems to suggest that plop leaves a dos compatible (16 bit real mode) driver in place.. so
the USB thumbdrive *should* continue to work during dos load or windows 16 bit realmode setup.
I undertand thsi to work this way because there are specific instructions for *unloading* the usb support once dos is
up & running so another usb driver can be loaded if wanted/needed.


Or the plop usb driver code in memory gets overwritten.. or corrupted.


i tried it and ...... you are right, it does not work. but i have an idea. the game is not over...



i started the windows installer from my boot manager with usb ;)

new boot manager with the fix is released.

but i have to say the installation goes very slow in combination with my boot manager. the performance will be better with the 5.1.0 version that comes in the future. meanwhile i suggest to copy the install files with linux to the hard disk and install windows from the hard disk

best regards



I'll have to give this a try!

..and nothing can be slower than the windows OS installer run from dos without smartdrv loaded ;-)

Took 6-7 hours on a mobile 1.8GHz notebook..

That will teach me not to (not) go through the trouble to load smartdrv..  :-)


Still have not been able to get it to work..
Using unetbootin I create from any kind of windows install CD or windows recovery console
from windowsXP/2003 iso or recovery console iso..

With latest boot loader I get the blue boot menu with "Default" at the top only..
try to boot it just flashes (flickers) and starts over (redraws the menu).

Menu has 10 second countdown that also tries every 10 seconds and does the same.