Author Topic: How to disable monitor turn off and disable kernel messages  (Read 8266 times)

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2452
  • a command shell is enough to do amazing things
How to disable monitor turn off and disable kernel messages
« on: April 16, 2010, 20:40:05 PM »
I got a few mails about how to disable the monitor turn off and the kernel messages, so i added it to the FAQ's and i post it here

How to disable monitor turn off

For the console use "setterm -blank 0" add it to the runme.sh.
To test it, enter it at the console.

For the X-Server (with gnome and fluxbox) use "xset -dpms s off" add it to the top of /root/.xinitrc
To test it, enter it at the terminal.


How to disable kernel messages

To disable the bootup kernel messages add to the "append" line in the isolinux.cfg (and similar) the parameter "quiet"

To disable the kernel messages on the console use "setterm -msg off" add it to the runme.sh
To test it, enter it at the console.

best regards
elmar

walterav

  • Jr. Member
  • **
  • Posts: 61
Re: How to disable monitor turn off and disable kernel messages
« Reply #1 on: May 15, 2010, 13:48:40 PM »
How to disable monitor turn off

For the console use "setterm -blank 0" add it to the runme.sh.
To test it, enter it at the console.

For the X-Server (with gnome and fluxbox) use "xset -dpms s off" add it to the top of /root/.xinitrc

To test it, enter it at the terminal.

Maybe off-topic but these 2 commands work great in a custom Ubuntu 10.04 with openbox when I type them in the 'terminal'. But I cannot find a runme.sh and /root/.xinitrc :P, as a normal Ubuntu uses GDM, do you happen to know where I can put these commands to make them sticky?
Somewhere in /etc/GDM/Xsession ?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2452
  • a command shell is enough to do amazing things
Re: How to disable monitor turn off and disable kernel messages
« Reply #2 on: May 15, 2010, 15:24:49 PM »
the following is ubuntu related but should work with other distros too

Maybe off-topic but these 2 commands work great in a custom Ubuntu 10.04 with openbox when I type them in the 'terminal'. But I cannot find a runme.sh and /root/.xinitrc :P, as a normal Ubuntu uses GDM, do you happen to know where I can put these commands to make them sticky?
Somewhere in /etc/GDM/Xsession ?

for the setterm command use /etc/rc.local
for the xset command use ~/.xsession

best regards
elmar