Author Topic: NMI received for unknown reason 35  (Read 15924 times)

arnab

  • Newbie
  • *
  • Posts: 12
NMI received for unknown reason 35
« on: May 19, 2010, 00:31:19 AM »
Hi,

First of thanks for creating such a wonderful distribution. I tried several linux versions but none I could boot so easily over the network because of my lack of knowledge in Linux. The help file in Ploplinux was very descriptive and was easy to follow and I could boot the entire operating system. However, I receive following errors and the system automatically keeps on rebooting.

NMI received for unknown reason 35
do you have a strange power saving mode?

What am I supposed to do?

Following are my system configuration.

1. IBM eserver x330
2. No HDD
3. PIII
4. No CD rom
5. 2GB RAM

Let me know if I have to provide more information.

Any help would be highly appreciated.

Thanks
Arnab

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #1 on: May 19, 2010, 09:03:44 AM »
hi,

NMI received for unknown reason 35
do you have a strange power saving mode?


hmm, i never had such an error. maybe it has to do with your ram's. are they old or new? did you change the timing in the bios?
you should start the memtest from the boot menu. maybe it finds something.

best regards
elmar

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #2 on: May 19, 2010, 14:40:27 PM »
The computer is old. 4-5 months back when the CDROM was working in this server, I used Ubuntu to boot up and it worked. There was no error. Now that I want to boot it from PXE(which I could not do with Ubuntu), it is showing up with ploplinux. When I use tinyucorelinux, I do not see this error.

I did memtest, but it did not show anything. All test passed.

how do i change the timing from bios?

to make sure that all is set correctly in bios, i did a reset to default setting.

it boots correctly, but due to this error, it reboots automatically. is there a way to stop it  from rebooting?

thanks
arnab

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #3 on: May 19, 2010, 15:01:53 PM »
in which stage of booting do you see the message in the first post you said you booted the entire system?
what do you see a few lines above?
are you able to enter commands at the command prompt?
does it boot immediately when you see the message?

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #4 on: May 19, 2010, 15:37:36 PM »
I see this message immediately after loading files from NFS and other connected storage devices. But this does not stop the system to boot. When the booting is finished, it gives me a rescue mode command line(although I did not select the rescue mode). Then it keeps on displaying this message in the command prompt automatically.

What I do is, press enter to get the prompt again and then i enter startx to boot the gui. GUI gets up, but immediately after the GUI is up, it reboots. I believe it this error which is causing it to reboot even though the entire system is up.

thanks
arnab

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #5 on: May 19, 2010, 15:41:43 PM »
"rescue" is the default hostname

when you are at the command prompt then run dmesg > dmesg.txt and post the dmesg.txt as attachment here

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #6 on: May 19, 2010, 15:46:05 PM »
i boot it using PXE. is there a way I can save the dmesg.txt file in the location from where it booted the OS?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #7 on: May 19, 2010, 15:51:53 PM »
there are so many ways. if the nfs mount is not configured to read only, then you are able to write to /media. or you put in an usb thumb drive and write it to the drive. or mount a samba network share, or upload via ftp, ...

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #8 on: May 19, 2010, 16:01:36 PM »
I faithfully followed the instructions given at http://www.plop.at/en/ploplinux.html#pxew

I wanted to make sure that I followed the instructions properly and I could boot the system properly instead of spending hours trying to figure out what to do by myself.(I spent hours in it in past).

According to the instructions, I modified the following lines to boot the files from network(just modified the IP address and removed the user/apss)

append initrd=initrfs.gz vga=1 smbmount=//192.168.1.103/ploplinux:"":""

Since after the boot, it does not give me much time to connect to a ftp server or connect a USB device and run the command, I would prefer that it boots with mounted system in Write mode.

With the above line, I am not sure if it is booting in Read only or write mode. Is it possible to change the parameter above and instruct the system to boot it in write mode so that when I get the prompt, I just have to type dmesg > dmesg.txt and the file gets saved in the location where it booted from?

This share "ploplinux" is in windows and I have allowed write access to all.

My questions may be trivial for advance linux users, but to me all this is too complicated because I spent hours to come to a successful running system and I could not do anything.

Thanks again for taking time to help me out

Arnab

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #9 on: May 19, 2010, 16:16:47 PM »
append initrd=initrfs.gz vga=1 smbmount=//192.168.1.103/ploplinux:"":""

This share "ploplinux" is in windows and I have allowed write access to all.

ok, its a windows share. i dont know why i was thinking you are using nfs.

however, if the share it as writeable like you say, then you should be able to write to /media which is the ploplinux directory on you windows pc.

run dmesg > /media/dmesg.txt

Since after the boot, it does not give me much time to connect to a ftp server or connect a USB device and run the command, I would prefer that it boots with mounted system in Write mode.


why dont you have time to connect?

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #10 on: May 19, 2010, 16:22:23 PM »
append initrd=initrfs.gz vga=1 smbmount=//192.168.1.103/ploplinux:"":""

This share "ploplinux" is in windows and I have allowed write access to all.

ok, its a windows share. i dont know why i was thinking you are using nfs.

however, if the share it as writeable like you say, then you should be able to write to /media which is the ploplinux directory on you windows pc.

run dmesg > /media/dmesg.txt

Since after the boot, it does not give me much time to connect to a ftp server or connect a USB device and run the command, I would prefer that it boots with mounted system in Write mode.


why dont you have time to connect?

I will send you report according to your instructions.

It does not give me much time to connect devices. It reboots quickly. By the time I would have connected something to the computer, it would reboot.

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #11 on: May 19, 2010, 18:28:53 PM »
Here I am attaching the dmesg.txt

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #12 on: May 19, 2010, 18:41:30 PM »
i don't know if that works

add acpi_pm_good to the append line:

change
append initrd=initrfs.gz vga=1 smbmount=//192.168.1.103/ploplinux:"":""
to
append initrd=initrfs.gz vga=1 smbmount=//192.168.1.103/ploplinux:"":"" acpi_pm_good


arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #13 on: May 19, 2010, 18:52:18 PM »
I am still getting the same error.


default linux
display boot.msg
timeout 100
prompt 1

label linux
kernel bzimage
append initrd=initrfs.gz vga=1 smbmount=//192.168.1.103/ploplinux:"":"" acpi_pm_good


label linuxfb
kernel bzimage
append initrd=initrfs.gz vga=0x318 smbmount=smbmount=//192.168.1.103/ploplinux:"":"" acpi_pm_good

label hd
localboot 0x80
append -

label plp
linux plpbt.bin

label plpinst
linux plpinst.com

label memtest
kernel memtest

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #14 on: May 19, 2010, 18:56:59 PM »
ok, remove the acpi_pm_good

i know you said that with ubuntu it worked fine, but only to be sure, remove all ram and insert only one. insert every ram you use for that pc alone and boot.

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #15 on: May 19, 2010, 19:08:55 PM »
ok...i think this process will take lots of time because I will have to open this big eserver and find out where the RAM is and then I will put one by one and test.

i will do this test after 4 hours from now and will update this thread with what I find out.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #16 on: May 19, 2010, 19:13:20 PM »
its also possible that its a problem with the kernel version and your pc. you can try an older plop linux version

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #17 on: May 19, 2010, 19:14:41 PM »
which version do you suggest me that I can use with graphics?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #18 on: May 19, 2010, 19:18:54 PM »
i would say, the first step is to find the problem, then its easy to continue

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #19 on: May 19, 2010, 19:20:05 PM »
i would say, the first step is to find the problem, then its easy to continue

its also possible that its a problem with the kernel version and your pc. you can try an older plop linux version

Well I thought you wanted me test it with a older version before I open the box to play with the RAM
« Last Edit: May 19, 2010, 19:22:19 PM by arnab »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2451
  • a command shell is enough to do amazing things
Re: NMI received for unknown reason 35
« Reply #20 on: May 19, 2010, 19:22:15 PM »
yes, but the graphic mode is not important for the test.

arnab

  • Newbie
  • *
  • Posts: 12
Re: NMI received for unknown reason 35
« Reply #21 on: May 20, 2010, 02:42:32 AM »
I tried several versions and had the same problem. At last before opening the box I thought of trying out a different linux. This time it looks like I got lucky. DSL worked just perfectly. It booted so fast and got me with browser and command line everything that a Java programmer would need. I just have to install the Java SDK and have to learn how to use network location for the work I do there.

Thanks for all the help you provided. I learnt how to SMB mount and several things during the process. Now I have to figure out how I can amend the isoconfig.cfg file to load the network location so that I do not have to load the location from command prompt.

Thanks
Arnab