Author Topic: Freeze on USB boot, even with Alt-u on EPoX 8K9A3+ mainboard  (Read 4007 times)

aklux

  • Newbie
  • *
  • Posts: 4
The EPoX 8K9A3+ is able to boot from USB out of the box, but it is dog slow, so I tried using Plop as a boot accelerator.

Unfortunately, when booting off an USB stick, choosing Plop, and then choosing USB, it just hangs (it shows the outline of the text box where the USB messages are supposed to go, but the box stays empty, not a single message logged, not even "Loading EHCI driver"). This happens even with Alt-u

However, if I boot Plop from floppy, while making sure that the USB stick is not yet plugged in when the floppy starts booting, the everything works ok. And boot from the stick is fast as hoped for (less than 10 seconds with Plop, versus almost 2 minutes without).

The freeze looks as if the BIOS somehow "locks" the USB device if it is already present during BIOS scan. Removing and reinserting the USB device when Plop menu is shown doesn't help :-(

Removing USB keyboard & mouse support (called "legacy USB support" on some other motherboards) doesn't help.

Removing "USB chip support" altogether in the BIOS does remove the freeze (messages are shown in USB log box), but also removes USB host hardwarewise (last message is "No boot device found...")

Unfortunately, this issue makes Plop rather useless as a standalone boot accelerator for USB sticks on that box...

Any ideas?

Thanks,

Alain

aklux

  • Newbie
  • *
  • Posts: 4
Re: Freeze on USB boot, even with Alt-u on EPoX 8K9A3+ mainboard
« Reply #1 on: June 28, 2011, 20:13:07 PM »
Any ideas anyone? Or are there some additional tests that I may run to help debug this issue?

It must be some call that stalls very early on in the process, before it even tries to print the first log message into the USB text box.

Thanks,

Alain

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2407
  • a command shell is enough to do amazing things
Re: Freeze on USB boot, even with Alt-u on EPoX 8K9A3+ mainboard
« Reply #2 on: June 28, 2011, 20:34:48 PM »
hi,
currently i have no time for bug searching and fixing.

regards
elmar

aklux

  • Newbie
  • *
  • Posts: 4
Re: Freeze on USB boot, even with Alt-u on EPoX 8K9A3+ mainboard
« Reply #3 on: June 28, 2011, 21:04:33 PM »
Ok, I understand

Don't hesitate to get back to me once you've got more time again!

thx

Alain

aklux

  • Newbie
  • *
  • Posts: 4
Re: Freeze on USB boot, even with Alt-u on EPoX 8K9A3+ mainboard
« Reply #4 on: August 08, 2011, 22:17:36 PM »
I just saw that there is a new version 5.0.13-test5 . Congratulations for this release; I'm glad you've found some time to work on plop again.

Unfortunately, the problem with the EPoX 8K9A3+ board still exists :-(

Thanks,

Alain