Author Topic: Plop Linux ver 4.0.6 on USB partition - won't boot  (Read 10142 times)

pathe3

  • Newbie
  • *
  • Posts: 9
Plop Linux ver 4.0.6 on USB partition - won't boot
« on: August 16, 2010, 01:43:30 AM »
I followed the instructions in Section 2.1. Make USB device bootable step-by-step with a slight modification; I am booting Plop Linux on a partition by chainloading it with GRUB4DOS.  The partition (sdb10) has Syslinux installed to the Partition Sector.  I tried both modes to boot, the standard Plop Linux menu entry and Plop Linux Framebuffer Mode.  It boots normally until it get to the point where it it searchs on usb cdrom, then it waits for usb cdrom drives again for 10 seconds.  After that, I get the message Plop Linux not found, starting busybox and nothing happens after that.  My netbook doesn't have a CDROM.  Any ideas?




thanx
« Last Edit: August 18, 2010, 10:11:53 AM by pathe3 »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #1 on: August 16, 2010, 09:54:57 AM »
thatnks for the info. its not your fault. its a problem with the detection on this extended partition. i will fix this.

best regards
elmar

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #2 on: August 16, 2010, 15:33:04 PM »
Thanks, yes I have it installed to an extended partition.  I have a screenshot of the bootup screen below.

« Last Edit: August 18, 2010, 10:12:38 AM by pathe3 »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #3 on: August 16, 2010, 15:42:34 PM »
i fixed it now, please try this version
http://download.plop.at/tmp/ploplinux-4.1.0-rc2.tgz

when you load it with syslinux, then you need syslinux 4.02

regards
elmar

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #4 on: August 16, 2010, 18:35:26 PM »
Thanks.  I will give it a try and post back the results.

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #5 on: August 18, 2010, 08:31:35 AM »
I know of no Linux distro that includes Syslinux ver 4.02, which is needed to install it to multiple partitions.  However, Ubuntu Maverick does include Syslinux 4.01.  I tried ver 4.01 and there was no change in the symptoms - I still got the same error messages on boot.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #6 on: August 18, 2010, 08:45:06 AM »
i assume you simply copied the ploplinux directory over the old one. without updating the kernel and initrd file. those files are in the isolinux directory. 4.1.0 has a kernel and initrd filename change to previous versions

meanwhile, i released the complete rc2 http://www.plop.at/en/ploplinuxdl.html
« Last Edit: August 18, 2010, 08:48:38 AM by Elmar »

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #7 on: August 18, 2010, 09:43:43 AM »
No, I deleted the old directories and installed the new ones.  I also updated the various files in the ISOLinux directory and the Syslinux directory with the Syslinux 4.01 kernels.  Anyway, I tried ploplinux-4.1.0-rc2 and there is a difference now.  I still can't boot, but the error changed to:

searching on usb drives
waiting for new usb drivessh: sdb10: bad number  (repeats about 15 times)
waiting for usb cdrom drives......................
no drive found
PloP Linux not found, starting busybox

« Last Edit: August 18, 2010, 10:10:51 AM by pathe3 »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #8 on: August 18, 2010, 09:53:14 AM »
ahh, my fault. i make a new update

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #9 on: August 18, 2010, 10:52:39 AM »
this should work now
http://download.plop.at/tmp/ploplinux-4.1.0-rc3.tgz

i made another change too, the isolinux directory is now merged with the syslinux directory

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #10 on: August 18, 2010, 18:26:16 PM »
I assumed that you meant that the old version of the Syslinux directory should be used for ploplinux-4.1.0-rc2 since only an ISOlinux directory was provided with that release.  I used the Syslinx directory with ploplinux-v4.0.6 instead with changes to the Syslinux kernels for ver 4.01.  I could have customized the Syslinux.cfg file if I had known that I should have used the ISOlinux directory instead.  Anyway, I did download the rc2 8mb Syslinux file and tried that too, but there wasn't any change.

Anyway, I'm not getting the same errors with rc3. However, I don't get a desktop either.  Is that normal?    Here is my boot up screen for rc3:


Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #11 on: August 18, 2010, 18:35:34 PM »
I assumed that you meant that the old version of the Syslinux directory should be used for ploplinux-4.1.0-rc2 since only an ISOlinux directory was provided with that release.

yes that was ok, but with rc3 i removed the isolinux directory, so from rc3 on, there exists only the syslinux directory in the future. currently its a bit difficult, because of the file name change with the new version.


Anyway, I'm not getting the same errors with rc3.

does it mean it works now from usb too?

However, I don't get a desktop either.  Is that normal?    Here is my boot up screen for rc3:

you have to copy opt.sqfs to the pluspacks directory


« Last Edit: August 18, 2010, 18:44:19 PM by Elmar »

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #12 on: August 18, 2010, 18:52:21 PM »
ls /dev/sdb10 gives "/dev/sdb10"

ls by itself gives "welcome.txt"

You mean create opt.sqfs in plus packs?  I don't see that file anywhere.

By the way, it does mount as sdb10, even though the screenshot shows hda10 (the screenshot is from using virtualbox)
« Last Edit: August 18, 2010, 19:08:16 PM by pathe3 »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #13 on: August 18, 2010, 18:56:22 PM »
ls /dev/sdb10 gives "/dev/sdb10"

ls by itself gives "welcome.txt"

ok

i modified my previous post before you made your last post

does booting work now from usb and the extended partition?

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #14 on: August 18, 2010, 19:02:15 PM »
I modified my post too.  Yes, it boots, but I get no desktop.  Where is opt.sqfs?

OK.  I read the instruction page and it says to download opt.sqfs.  I will try that.
« Last Edit: August 18, 2010, 19:10:39 PM by pathe3 »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #15 on: August 18, 2010, 19:13:46 PM »
the opt.sqfs is in the X version of plop linux. its uptdated too with 4.1.0

either you wait for the download link on the download page, or you download
http://download.plop.at/files/ploplinux/ploplinux-v4.1.0-rc2-X.iso
and copy the pluspacks directory to your current working plop linux. open the iso with the midnight commander or "mount [isofile] -o loop /mnt"

autostart of X is not activated by default. because the real plop linux is without X, but with opt.sqfs you get gnome and fluxbox and much more.

you start gnome with "startx" (when opt.sqfs is in pluspacks). to activate autostart X uncomment the autostartx line in "ploplinux/myscripts/runme.sh"


it looks like we are async ;)
« Last Edit: August 18, 2010, 19:18:37 PM by Elmar »

pathe3

  • Newbie
  • *
  • Posts: 9
Re: Plop Linux ver 4.0.6 on USB partition - won't boot
« Reply #16 on: August 18, 2010, 19:18:48 PM »
Yes, I realized that before you posted.  It's explained on the home page for PLoP Linux.  Now I know why this distro was so tiny.  Guess I will have to expand my partition now, lol.

Actually, it's useful to have this startup option between the shell and Gnome desktop.
« Last Edit: August 18, 2010, 19:42:56 PM by pathe3 »