Author Topic: "Missing OS" on Acer Aspire 1300  (Read 6971 times)

Elan67

  • Newbie
  • *
  • Posts: 5
"Missing OS" on Acer Aspire 1300
« on: November 05, 2009, 10:20:31 AM »
I've tried latest 5.0.4 plop BM on Acer Aspire 1300, trying to boot from diskette a 4 Gb USB pen but I stuck on "Missing Operating System", any suggestion?

Thanks
Valerio

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: "Missing OS" on Acer Aspire 1300
« Reply #1 on: November 05, 2009, 10:29:04 AM »
hi,
there are some reasons why this can happen.
maybe if your pen drive is FAT formatted then i think its not in LBA format.
is the partition activated to boot?
what system is on the pendrive and how did you make it bootable. did you partition and format it by your self?

regards
elmar

Elan67

  • Newbie
  • *
  • Posts: 5
Re: "Missing OS" on Acer Aspire 1300
« Reply #2 on: November 05, 2009, 10:47:07 AM »
thank so much for answer.
Pen is fat16 and here is parted output:

Code: [Select]
Disk /dev/sdb: 4043MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags   
 1      32.3kB  4043MB  4043MB  primary  fat16        boot, lba
Do you think there is something wrong?

Pen is booting right on USB boot supported systems.
Os is windows 2008 server installation dvd, of course I don't even think to install it with this notebook! It is just the only usb bootable pen I have around to test plop functionality.
I really don't remember how it was formatted/created, it was some ago.

Valerio
« Last Edit: November 05, 2009, 10:52:04 AM by Elan67 »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: "Missing OS" on Acer Aspire 1300
« Reply #3 on: November 05, 2009, 11:05:48 AM »
please post the output file sectors.bin
Code: [Select]
dd if=/dev/sdb of=sectors.bin count=64

Elan67

  • Newbie
  • *
  • Posts: 5
Re: "Missing OS" on Acer Aspire 1300
« Reply #4 on: November 05, 2009, 11:11:49 AM »
Here is..

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: "Missing OS" on Acer Aspire 1300
« Reply #5 on: November 05, 2009, 11:31:33 AM »
what happen when you try the attached file?
Code: [Select]
dd if=mbr.bin of=/dev/sdb

Elan67

  • Newbie
  • *
  • Posts: 5
Re: "Missing OS" on Acer Aspire 1300
« Reply #6 on: November 05, 2009, 11:45:53 AM »
WOW!!! It works!
excellent!

What was wrong?

Thank you
Valerio
« Last Edit: November 05, 2009, 11:47:27 AM by Elan67 »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: "Missing OS" on Acer Aspire 1300
« Reply #7 on: November 05, 2009, 11:50:10 AM »
the mbr program was not good. i think it was the original program from your pen manufacture.

you can fix this in the future with
Code: [Select]
lilo -M /dev/sdb

best regards
elmar

Elan67

  • Newbie
  • *
  • Posts: 5
Re: "Missing OS" on Acer Aspire 1300
« Reply #8 on: November 05, 2009, 12:05:38 PM »
Solved! thanks Elmar,
you are simply SUPER!

Valerio