Author Topic: Custom BIOS with Plop - not working [SOLVED]  (Read 12670 times)

martyrdom

  • Newbie
  • *
  • Posts: 7
Custom BIOS with Plop - not working [SOLVED]
« on: March 13, 2011, 03:54:50 AM »
Hi,
I've just flash my laptop with new bios.
I've added plop boot mgr to the bios (according to the manual i replaced my network card module).
And... nothing happen... I don't see any menu and I can't boot from USB.
How to check if is the boot mgr realy in my bios?
« Last Edit: March 14, 2011, 22:38:08 PM by martyrdom »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #1 on: March 13, 2011, 10:27:09 AM »
hi,
do you see the boot manager in the list of the bootable devices at the place where you setup the boot sequence?

elmar

martyrdom

  • Newbie
  • *
  • Posts: 7
Re: Custom BIOS with Plop - not working
« Reply #2 on: March 13, 2011, 12:06:58 PM »
No, I don't see it.
I have the same boot options in BIOS like before.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #3 on: March 13, 2011, 12:09:07 PM »
send me the original and modified bios rom as private message

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #4 on: March 13, 2011, 14:59:20 PM »
whats the vendor and device id of your network card?

martyrdom

  • Newbie
  • *
  • Posts: 7
Re: Custom BIOS with Plop - not working
« Reply #5 on: March 13, 2011, 16:07:09 PM »
My network card is 82801db pro/100
Vendor ID: 0x8086
Device ID: 0x103D
(I used lspci command under linux and pci&agp info tool)

I wonder what is a device [vendror id: 0x8086 ; device id 0x101e].
I can see that module file in my bios opened in MMTOOL but it doesn't exist in my notebook.
I can't find it using lspci or any diagnostic software. Maybe I can try to replace this module with Plop?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #6 on: March 13, 2011, 17:38:30 PM »
does the pxe option rom starts when you use network boot as first boot option with your original rom?

martyrdom

  • Newbie
  • *
  • Posts: 7
Re: Custom BIOS with Plop - not working
« Reply #7 on: March 13, 2011, 17:47:02 PM »
Yes, it does.
And it also does with patched BIOS.
It says, that network cable is wrong or not connected (it is not connected in fact)

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #8 on: March 13, 2011, 17:55:20 PM »
flash the bios with your patched version
load the rom from the bios chip and send me this file

martyrdom

  • Newbie
  • *
  • Posts: 7
Re: Custom BIOS with Plop - not working
« Reply #9 on: March 13, 2011, 21:30:57 PM »
OK, finaly I dumped it but it wasn't so easy - I don't have any OS on HDD.
I try to flash it again. This time I've checked option to program boot block.
Only one difference I've got is that option to boot from network (in bios setup) is gone. I can chose from: ufb-fdd, cd/dvd, hdd. Previously there was Network also.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #10 on: March 14, 2011, 07:34:31 AM »
i have no idea why its doesn't work :(

martyrdom

  • Newbie
  • *
  • Posts: 7
Re: Custom BIOS with Plop - not working
« Reply #11 on: March 14, 2011, 18:53:23 PM »
Mayby I messed up with plpcfgbt?
My options are:
Code: [Select]
Video mode     : 1024x768
Start mode     : menu
Countdown      : off
Countdown value: 99 seconds
Default boot   : usb
Profile        : 1
Starfield      : on
Zoom animation : on
Font           : bootmanager
Force USB 1.1  : off
Use USB MassDev: 1
Use INT19h     : on
Startup hotkey : yes
Skip PCMCIA    : no
Fast PCMCIA    : no

Or maybe there is something wrong with plpbtrom.exe settings?
I simple set my device id and vendor id like that:
Code: [Select]
plpbtrom -vendorid 0x8086 -deviceid 0x103d plpbtrom.bin plpbt.romIs the above correct for my config.?

I've never did it before. What should I see in BIOS Setup after reflashing?
Should it be something like "Plop Boot Mgr" instead of "Network"?

Mayby I can try to replace module I mentioned before: [vendror id: 0x8086 ; device id 0x101e]?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #12 on: March 14, 2011, 21:44:57 PM »
Use INT19h     : on

this should be off, but its not related to the problem

I've never did it before. What should I see in BIOS Setup after reflashing?
Should it be something like "Plop Boot Mgr" instead of "Network"?

it depends to the bios, but in your case, there should be something with "plop"

martyrdom

  • Newbie
  • *
  • Posts: 7
Re: Custom BIOS with Plop - not working
« Reply #13 on: March 14, 2011, 22:37:49 PM »
I can't belive it but finaly I did it!
I did everything the same and only one difference was that I didn't use plpcfgbt at all.
There is sometching wrong about plpcfgbt.exe (same for gui).
It showed me that my rom file is configured for text mode, no stars animation, bios font etc. I didn't change any option, just replace module in my BIOS and flash.
And now there is a Plop Boot Manager in Bios setup (instead of Network) and when it starts it's like a menu and there is a stars animation, zoom windows etc. Weird, isn't it?
The best thing is that I can finally boot from USB! :)
Elmar - thanks for your support!

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2491
  • a command shell is enough to do amazing things
Re: Custom BIOS with Plop - not working
« Reply #14 on: March 15, 2011, 19:09:07 PM »
I did everything the same and only one difference was that I didn't use plpcfgbt at all.
There is sometching wrong about plpcfgbt.exe (same for gui).
It showed me that my rom file is configured for text mode, no stars animation, bios font etc. I didn't change any option, just replace module in my BIOS and flash.

this explains everything. plpcfgbt MUST NOT be used with the rom. it must be used with plpbt.bin. when plpbt.bin is configured then you have to create the rom file.

when you configure the rom with plpcfgbt, then the rom checksum is wrong and the bios ignores this rom. however, plpcfgbt would configure wrong bytes, so it would never work.

do dont forget:
use plpcfgbt with plpbt.bin
then use plpbtrom and plpbt.bin to create the rom

best regards
elmar