Author Topic: running ploplinux on i586  (Read 33499 times)

toddjerret

  • Newbie
  • *
  • Posts: 36
running ploplinux on i586
« on: December 02, 2010, 11:02:43 AM »
hello,

I am trying to run plop from the network on two thin-clients.
it works on one and the other gets a kernel-panic soon after starting.

the main diferent is that one has i686 processor and one has i586 processor.
is it posible that plop dous not support i586?

with regards

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #1 on: December 02, 2010, 11:10:37 AM »
hi,
ploplinux is compiled to run on i486, so it should work on an i586. can you post a photo of your monitor with the kernel panic?

regard
elmar

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #2 on: December 02, 2010, 11:20:57 AM »
hi,
thanks for the quick replay,

I am trying to get it running on a ebox-3300mx like in www.wdlsystems.com

the screen cannot be captured, I can copy it to paper and then write it down.

the panic line is: Kernel Panic - not syncing: attempted to kill init!

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #3 on: December 02, 2010, 11:25:49 AM »
i mean, simply make a photo with a camera and post it.

or write down the 4 lines before the kernel panic

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #4 on: December 02, 2010, 11:45:27 AM »
ok, the few lines before the panic are:

wbsd: winbond w83151xd sd/mmc card interface driver
wbsd: copyright (c) pieere ossman
usbcore: registrated new interfacedriver usbhid
usbhid: v.2.6:usb hid core driver
tcp cubic registrated
net: registrated udp transport module
net: registrated tcp transport module
freeing unused kernel memory: 472k freed


hope you can make something out of this

todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #5 on: December 02, 2010, 12:03:18 PM »
replace this test initramfs.gz with yours (in syslinux/kernel/).
http://download.plop.at/tmp/initramfs.gz

is there still a kernel panic?

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #6 on: December 02, 2010, 12:48:51 PM »
hi,

just wanted to be sure : the file you posted replaces initrfs.gz witch is in the same directory as my bzimage file - correct ??

if so the behavior is the same = kernel panic

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #7 on: December 02, 2010, 12:57:52 PM »
it seems you are not using the latest ploplinux version. when you use an older version then you have to replace it with initrfs.gz (as you did).

here is a second test file http://download.plop.at/tmp/initramfs2.gz

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #8 on: December 02, 2010, 13:10:32 PM »
you are correct, I am using the 3.8.4 version.

the second version gives the same result .

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #9 on: December 02, 2010, 13:19:40 PM »
its possible that its a problem with the squashfs 3.x decompression. is there any reason for using the old ploplinux version? you should try a new version

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #10 on: December 02, 2010, 13:29:57 PM »
the reason is that i have a running environment with 3.8.4 version.
I will try to download the newest version and let you know how it went.

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #11 on: December 02, 2010, 14:47:53 PM »
I downloaded the 4.1 version and copyed it to the right directory's.

when booting I get the folowing:

decompressing Linux ... Parsing ELF ... done.
Booting the Kernel.


and the kursor is blinking and blinking

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #12 on: December 02, 2010, 14:55:47 PM »
no other output? did you add the "quiet" parameter? if yes, then remove it

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #13 on: December 02, 2010, 15:02:14 PM »
no, this is the strange thing...
nothing else on the screen.

on another thinclient of another brand it go's all the way to level3 prompt.


Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #14 on: December 02, 2010, 15:07:54 PM »
you try to start without framebuffer mode?

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #15 on: December 02, 2010, 15:10:43 PM »
sorry for asking but - how do i do that ??

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #16 on: December 02, 2010, 15:14:58 PM »
when you use no vga parameter or vga=1 then you start without framebuffer
btw. how much ram do you have in the pc?

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #17 on: December 02, 2010, 15:22:19 PM »
I have vga=1 in all my images allready.
it has 500MB ram and no disk as the machine is booting from the network .
any ideas?

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #18 on: December 02, 2010, 15:40:32 PM »
add pnpbios=off after vga=1

it seems the ebox-3300 has some problems with 2.6 kernels

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #19 on: December 02, 2010, 15:55:05 PM »
same response on 3.8.4 and 4.1.0 with pnpbios=off

still the same.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #20 on: December 02, 2010, 16:20:58 PM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #21 on: December 05, 2010, 07:17:05 AM »
Hi Elmar,

took a few days of ...

tryed the temp kernel you sent and no luck.
the dump on the screen looks diferent :

cpuid: using governor ladder
cpuid: using governor menu
using IPI No-shortcut mode
Magic Number: 4:974:810
Freeing unused Kernel memory
Write protecting the kernel text: 2164k
Write protecting the kernel read-only data 836k
init used greatest stack depth 6804 bytes left
Kernel panic - not syncing: Attempted to kill init!

hope again this meens somthing to you

regards

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #22 on: December 05, 2010, 07:19:46 AM »
thats a step forward, i give you a new test kernel

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #23 on: December 05, 2010, 07:52:39 AM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #24 on: December 05, 2010, 08:05:21 AM »
well after trying the two new kernel the output is the same except for
after the Call Trace dump a new line is there that says:

ohci-hcd 000:00:ob.0: auto-stop root hub

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #25 on: December 05, 2010, 08:07:42 AM »
do you see those lines at the end? (the values are not important)

Write protecting the kernel text: 2164k
Write protecting the kernel read-only data 836k
init used greatest stack depth 6804 bytes left
Kernel panic - not syncing: Attempted to kill init!

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #26 on: December 05, 2010, 08:13:09 AM »
yes, the lines are the same.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #27 on: December 05, 2010, 08:30:09 AM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #28 on: December 05, 2010, 08:42:10 AM »
with the bzimage4 the result is back to :

decompressing Linux ... Parsing ELF ... done.
Booting the Kernel.

and nothing else

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #29 on: December 05, 2010, 08:57:17 AM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #30 on: December 05, 2010, 09:03:31 AM »
with the bzimage5 its the same :

decompressing Linux ... Parsing ELF ... done.
Booting the Kernel.

and nothing else

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #31 on: December 05, 2010, 09:16:24 AM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #32 on: December 05, 2010, 09:44:58 AM »
again thanks for your help but:

Registrated taskstat version 1
using IPI No-shortcut mode
Magic Number: 4:443:463
Freeing unused Kernel memory
Write protecting the kernel text: 2164k
Write protecting the kernel read-only data 836k
init used greatest stack depth 6804 bytes left
Kernel panic - not syncing: Attempted to kill init!
Pid:1, comm: init Not tainted 2.6.36.1 #6
Call trace:
.......................................................

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #33 on: December 05, 2010, 09:58:52 AM »
i think i now whats wrong
new test http://download.plop.at/tmp/bzImage7

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #34 on: December 05, 2010, 10:23:17 AM »
with bzimage7 - same result.

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #35 on: December 05, 2010, 10:40:41 AM »
i think you see "init used greatest..."
new test http://download.plop.at/tmp/bzImage8

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #36 on: December 05, 2010, 10:54:12 AM »
same result with the big filesize bzimage8,

and fyi - "init used greatest..." is not there from the bzimage2 and up to bzimage8.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #37 on: December 05, 2010, 10:57:23 AM »
and fyi - "init used greatest..." is not there from the bzimage2 and up to bzimage8.

but you posted it with bzimage6

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #38 on: December 05, 2010, 11:00:39 AM »
sorry, my bad.
you are correct, in bzimage6 it was there and in bzimage7 and bzimage8 it was not.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #39 on: December 05, 2010, 11:16:20 AM »
new test http://download.plop.at/tmp/bzImage9
its important that it goes to "init used greatest..."

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #40 on: December 05, 2010, 11:29:08 AM »
nothing changed.

same results with no  "init used greatest..." (I checked and double checked)

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #42 on: December 05, 2010, 12:37:06 PM »
same result with bzimage10,11 with ither plop3.8.4 and plop4.1.0.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #43 on: December 05, 2010, 12:38:38 PM »
no "init used greatest..." on the screen?

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #44 on: December 05, 2010, 12:43:51 PM »
no, I am positive cos I know it is importent.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #45 on: December 05, 2010, 12:45:10 PM »
« Last Edit: December 05, 2010, 13:24:26 PM by Elmar »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #46 on: December 05, 2010, 13:59:48 PM »
as you emphasise the "init used greatest..."  line,
I tryed to load the bzimage6 again and I can not see this line again.
no metter what i do (diferent versions and diferent initram files, tryed downloading the image again from the link...)

I can not explain it and I tripled checked it.
I don't know what has changed .

p.s. with the latest bzimage12 the results are the same.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #47 on: December 05, 2010, 14:18:57 PM »
http://download.plop.at/tmp/bzImage13

you have to test only with 4.1.0. currently only the kernel is loaded, so either it woks or it doesn't.

"results are the same" can mean a lot, so
when it hangs right after the message "booting the kernel." simply write "bad".
when it goes up to "init used greatest" then write "ok".
when it hangs between those 2 states, then tell me what you see.


toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #48 on: December 05, 2010, 14:29:58 PM »
well..  OK. for bz13

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #49 on: December 05, 2010, 14:49:10 PM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #50 on: December 05, 2010, 15:12:18 PM »
bz14 - kernel panic- with NO "init used greatest..." .

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #51 on: December 05, 2010, 15:14:23 PM »
what are the last 3 lines?

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #52 on: December 05, 2010, 15:29:07 PM »
Write protecting the kernel text: 2164k
Write protecting the kernel read-only data 836k
Kernel panic - not syncing: Attempted to kill init!
Pid:1, comm: init Not tainted 2.6.36.1 #15
Call trace:
.......................................................
.......................................................
.......................................................
.......................................................
.......................................................
.......................................................
ohci-hcd 000:00:ob.0: auto-stop root hub

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #53 on: December 05, 2010, 15:37:14 PM »
ok, this is perfect.
can you try to boot with the bzImage14 and the original initramfs.gz from 4.1.0

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #54 on: December 05, 2010, 15:51:21 PM »
tryed it with the same results.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #55 on: December 05, 2010, 15:53:13 PM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #56 on: December 05, 2010, 16:04:26 PM »
same as before only one line added before the magoc number line:
hash maches drivers/base/power/main.c: 525

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #57 on: December 05, 2010, 16:08:22 PM »
I have to leave for today,
I appreciate your help alot.

Tod

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #58 on: December 05, 2010, 21:56:20 PM »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #59 on: December 06, 2010, 06:56:31 AM »
Hi,
this looks alot better.
it start to roll the start lines and then it stops at:

INIT: Entering runlevel:3
INIT: cannot execute "/etc/rc.d/init.d/rc

p.s. I connect it to the 4.1.0 sqfs files and pluspack from the 3.8.4 with all my scripts and files.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #60 on: December 06, 2010, 09:30:57 AM »
you have to use all sqfs files from the test package.

you have to copy your own scripts to ploplinux/bin/ but this only needed when the ploplinux booting works

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #61 on: December 06, 2010, 10:08:44 AM »
works fine :)

know I have to migrate all my workspase to the new environment.
the opt has an old sqfs version so it will not load and I will have to figure out the changes from the old version.
I will try to do it and will let you know how it went.

thank you very mouch for your help and dedication thru the last few days.

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #62 on: December 06, 2010, 10:18:49 AM »
fine. btw. the problem was
kernel: not rerouting broken irq's
init: glibc, i recompiled it with the correct setting --build=i486-pc-linux-gnu

you can use the opt.sqfs from 4.1.0 http://www.plop.at/en/ploplinuxdl.html
save it in ploplinux/opt/

best regards
elmar
« Last Edit: December 06, 2010, 14:16:07 PM by Elmar »

toddjerret

  • Newbie
  • *
  • Posts: 36
Re: running ploplinux on i586
« Reply #63 on: December 06, 2010, 15:44:08 PM »
Hi,

allmost averything is working fine.
I am having problem with "No soundcard found" in all of the devices I tryed it on (some work fine with the 3.8.4 version)

Todd

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2434
  • a command shell is enough to do amazing things
Re: running ploplinux on i586
« Reply #64 on: December 06, 2010, 15:49:58 PM »
add the command "pciprobe" to ploplinux/bin/rc.local