Author Topic: Nothing loads, except the Plop Boot Manager  (Read 10208 times)

Dommy

  • Newbie
  • *
  • Posts: 6
Nothing loads, except the Plop Boot Manager
« on: December 14, 2010, 15:50:13 PM »
Hello there, I downloaded the PLoP Boot Manager today and wanted to install XP on my PC with W7.
So I restarted and I couldnt do anything, well I tried to boot from DVD/CD, then I tried to boot from my USB. Nothing. Well thats not the worst. The big problem is that I CANT GO TO MY OS ANYMORE. I cant even change that Plop dont starts up. My Computer is just useless (btw my new Nvidia GTX 465 comes tomorow lol)

So what to do. I just can go to the Bios, but I cant do anything over there so am I screwed? Do I need to buy a new HDD ? Come on..... Help quick plz

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2471
  • a command shell is enough to do amazing things
Re: Nothing loads, except the Plop Boot Manager
« Reply #1 on: December 14, 2010, 18:16:26 PM »
what do you mean that you can't do anything? does the keyboard work?
what do you see on the screen?

regards
elmar

Dommy

  • Newbie
  • *
  • Posts: 6
Re: Nothing loads, except the Plop Boot Manager
« Reply #2 on: December 14, 2010, 18:25:58 PM »
Keyboard works, yeah. But I cant even use the command promp, because nothing is loading. On the screen I see
HDA PARTITION 1
HDB PARTITION 1
FLOPPY
CDROM
USB in green.
I can go to the Bios, but cant change something there, I tihnk.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2471
  • a command shell is enough to do amazing things
Re: Nothing loads, except the Plop Boot Manager
« Reply #3 on: December 14, 2010, 18:28:46 PM »
how did you install the boot manager?

Dommy

  • Newbie
  • *
  • Posts: 6
Re: Nothing loads, except the Plop Boot Manager
« Reply #4 on: December 14, 2010, 18:31:34 PM »
I downloaded some tool and checked the PLoP marker I THINK.

Well I cant check because I cant go to my Pc, im on with my Laptop.
Then I restarted it and nothing came up, except the PLoP

I also cannot change that the counter goes down from 15 to 0 or so.
Well I can but it doesnt work.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2471
  • a command shell is enough to do amazing things
Re: Nothing loads, except the Plop Boot Manager
« Reply #5 on: December 14, 2010, 18:39:01 PM »
that the text that you see from the boot manager in combination that you said its the first after the bios and i think you boot from the hard disk, makes no sense to me.

did you download the tool from plop.at?
what is happening when you boot hda partition 1?

Dommy

  • Newbie
  • *
  • Posts: 6
Re: Nothing loads, except the Plop Boot Manager
« Reply #6 on: December 14, 2010, 18:47:31 PM »
A little window pops up, then i see the Plop screen again. I dont know anymore where I got this from, but i think so.
hdb partition 1 is the same, except of the Plop screen I see a black screen:

Starting cmain() ... (hd0,0)

Load segment: 0x0   System Type: 0x0   Sector Count: 0x4
Load RBA: 0x21   Boot Type: 0 = No Emulation

ISOLINUX 3.73 3.73 ETCD Copyright (C) 1994-2008 H. Peter Anvin
Loading plpbt.bin.....ready.


Disk error
Press any key to restart
-I press the key-
Missing operating system.

And I cant do anyhitng

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2471
  • a command shell is enough to do amazing things
Re: Nothing loads, except the Plop Boot Manager
« Reply #7 on: December 14, 2010, 18:54:10 PM »
this sounds to me you are starting
grub -> loading the boot manager iso -> plop boot manager

what have you done?

Dommy

  • Newbie
  • *
  • Posts: 6
Re: Nothing loads, except the Plop Boot Manager
« Reply #8 on: December 14, 2010, 18:56:40 PM »
Can I add you on a messenger like msn, icq or skype ? It would be alot easier for me.

I dont know what you mean

Dommy

  • Newbie
  • *
  • Posts: 6
Re: Nothing loads, except the Plop Boot Manager
« Reply #9 on: December 14, 2010, 21:04:43 PM »
Does the Disk matter ? I just threw a new burned XP DVD in my Pc and nothing happens, again.
Oh god, i am screwed.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2471
  • a command shell is enough to do amazing things
Re: Nothing loads, except the Plop Boot Manager
« Reply #10 on: December 16, 2010, 06:47:30 AM »
we talked offline, the computer runs now (after wasting a lot of time)

a quick overview what happened:
  • dommy used easybcd to add the boot manager floppy to the windows
  • he removed the windows boot entry from the windows boot menu (a very very bad idea)
    after that, the plop boot manager entry was the only entry and became the default one and was started automatically
  • pc power on -> bios -> mbr -> windows boot sector -> windows boot manager -> plop boot manager
  • so, how to fix this and add a new windows boot entry?
  • you have to boot the windows install dvd and choose repair and then the command prompt option

infos from neosmart wiki
Quote
bcdedit.exe /create /d "Windows Vista" /application osloader

bcdedit.exe should return a message with a GUID for the newly-created entry, something like this:
The entry {c0dfc4fa-cb21-11dc-81bf-005056c00008} was successfully created.

You'll need to use the value that bcdedit.exe returned for you below, along with the drive letter for the drive that Windows Vista is installed to:
bcdedit.exe /set {c0dfc4fa-cb21-11dc-81bf-005056c00008} device partition=C:
bcdedit.exe /set {c0dfc4fa-cb21-11dc-81bf-005056c00008} osdevice partition=C:
bcdedit.exe /set {c0dfc4fa-cb21-11dc-81bf-005056c00008} path \Windows\system32\winload.exe
bcdedit.exe /set {c0dfc4fa-cb21-11dc-81bf-005056c00008} systemroot \Windows

And, last of all, tell the Vista bootloader to boot the new entry by default:
bcdedit.exe /displayorder {c0dfc4fa-cb21-11dc-81bf-005056c00008}
bcdedit.exe /default {c0dfc4fa-cb21-11dc-81bf-005056c00008}

more info and a special recovery dvd see here http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD

however, dommy had no original dvd and the self burned did not start from the bios dvd boot option.
he found suddenly a dvd that was able to boot from the bios dvd boot option.

Conclusion
overall, i spent 3 hours for this. with telling what he has to do in the ploplinux comand line and a lot of other things. at the end as the widows dvd booted,

he said "it looks like its installing now"
i said "you should stop this before you lost your data"
he said "keeping the data is not important for me"
i thought thats a bad joke  :o
he said "it doesn't matter because i wanted to install xp, thats why i installed the plop boot manager".
(original conversation in german)

oh man, losing 3 hours for something that can be solved within a few minutes!

what did i learn? ignore people that needs quick help, mostly its not urgent. it seems its required to ask people if they want to keep their data or not.

elmar