Author Topic: BIOS boots USB as A:\  (Read 14136 times)

jordos

  • Newbie
  • *
  • Posts: 5
BIOS boots USB as A:\
« on: October 04, 2009, 16:49:00 PM »
Thought this might be the right place to ask:

I've been working on a DOS USB stick, but am experiencing many difficulties. I managed to install Freedos on it without too much problems on a fairly modern pc with proper USB booting support. Unfortunately, the PC I intended to use it on for most of the time did not have proper USB boot support. PLOP manager came to the rescue but then EMS memory suddenly stopped working. I finally read this was because of an incompatibility with plop's USB drivers (and not because of my CONFIG.SYS&AUTOEXEC.BAt fiddling as I originally thought). Ofcourse, I can't just unload the plop USB drivers and load the DOS USB drivers after that as this would halt startup with a read error.

Now to the main question: the BIOS is not entirely hopeless, it does support USB booting, but maps the drive to A instead of C, crashing freedos on startup. (Edit: at least, that's what I think is happening) Unfortunately I don't see any other options in the BIOS that might change this (no distinction between USB floppy or HD or whatever). Anyone have an idea or is it impossible?


The motherboard is an Asrock K7VT4A Pro, already flashed the BIOS to the latest version (AMI P1.80)
« Last Edit: October 04, 2009, 17:09:49 PM by jordos »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2430
  • a command shell is enough to do amazing things
Re: BIOS boots USB as A:\
« Reply #1 on: October 04, 2009, 20:32:06 PM »
but maps the drive to A instead of C, crashing freedos on startup.

i think you are meaning that the drive letter is wrong because of a: and this is the crash of freedos. if its so, then remove the drive letters in the config.sys and autexec.bat.

regards
elmar

jordos

  • Newbie
  • *
  • Posts: 5
Re: BIOS boots USB as A:\
« Reply #2 on: October 04, 2009, 20:46:42 PM »
I thought of that, but will it suffice? I can't edit what's in the kernel for instance. I'll give it a try though.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2430
  • a command shell is enough to do amazing things
Re: BIOS boots USB as A:\
« Reply #3 on: October 04, 2009, 20:52:12 PM »
the config.sys of freedos is fdconfig.sys

jordos

  • Newbie
  • *
  • Posts: 5
Re: BIOS boots USB as A:\
« Reply #4 on: October 04, 2009, 21:25:24 PM »
Unfortunately it didn't work, Freedos still hangs when booting from USB directly. I edited out all references to C:\ in autoexec.bat and fdconfig.sys.
After it says 'looking for boot record from USB-something... OK' it prints 'Freedos Kernel... Fat' and after that nothing else happens. The drive is formatted in FAT(16).
« Last Edit: October 04, 2009, 21:31:23 PM by jordos »

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2430
  • a command shell is enough to do amazing things
Re: BIOS boots USB as A:\
« Reply #5 on: October 05, 2009, 09:06:14 AM »
can you zip your freedos and post it? if you dont want to post it, send me a private message and i give you my email address.

jordos

  • Newbie
  • *
  • Posts: 5
Re: BIOS boots USB as A:\
« Reply #6 on: October 05, 2009, 13:58:29 PM »
Sure, no problem. The configuration is not standard, but it works fine with plop boot manager, except for the EMS part. I left out my SOUND folder (soundcard driver which was 16MB unzipped) so the part that refers to is in autoexec.bat won't work.
I hope rar is ok?
http://users.telenet.be/V776822/FDOS.rar

maanu

  • Newbie
  • *
  • Posts: 3
Re: BIOS boots USB as A:\
« Reply #7 on: October 06, 2009, 17:30:45 PM »
one reason is , your bios sees your usb stick as a floppy disk . but im not sure .

jordos

  • Newbie
  • *
  • Posts: 5
Re: BIOS boots USB as A:\
« Reply #8 on: October 13, 2009, 23:39:32 PM »
Do you mean it might work with a different USB stick?

dukenukeme

  • Newbie
  • *
  • Posts: 17
Re: BIOS boots USB as A:\
« Reply #9 on: March 14, 2010, 01:56:00 AM »
sory for old thread , please try this
a bit different variant of freedos (it is called balder)
http://www.finnix.org/Balder
it has FDXMS (replacement for himem&emm386)
safe mode usualy just works.
loadcd.bat loads cdrom drivers on the fly

usb memory may be detected as A: or B: when booted using motherboards usb boot
this is usualy if mobo has recognised usb memory as USB ZIP
may be slow, on other hand may have RW capabilities to usb.

EDIT
i think XMS memory managers from DOS may be having conflicts
in combination to PloP's usb driver (not allways) :-\
(sometimes the content of usb stick is garbled when chosen this option himem or emm386 or fdxms)

FDXMS appears to allocates 1 GB to 4GB of RAM to be used from inside DOS , i found it unbelievable :D .
« Last Edit: March 16, 2010, 11:21:23 AM by dukenukeme »

johnlou

  • Newbie
  • *
  • Posts: 1
Re: BIOS boots USB as A:\
« Reply #10 on: May 16, 2010, 02:57:26 AM »
 i have a Toshiba Satellite 1110  laptop and the cd rom drive is not working,  and im wanting to format the h/drive but unable to .

  i have tried to set the bios for an external cd-rom drive but there is no settings for this.
  a computer tech suggested that i " create a bootable usb windows drive disk "   
  my laptop  o/s is xp and i want to keep it

  can someone give me a step by step on how to do this ( including links for any downloads that i might need ) or a web-addy   that will help me


 thanx in advance   John

dukenukeme

  • Newbie
  • *
  • Posts: 17
Re: BIOS boots USB as A:\
« Reply #11 on: May 17, 2010, 22:48:18 PM »
hi do you have any option for -usb boot- in bios ?

may i suggest to
1. first create fat or fat32 partition and put /i386 folder from cdrom
then boot into DOS and/or do as instructed here
http://paulski.com/zpages.php?id=1711

2. but first Dos needs to be put on usb stick
(somehow perhaps here or search forum ;)
http://www.bay-wolf.com/usbmemstick.htm ? )

3.if your cd drive is just sligthly malfunctional there is chance
you may boot DOS from cdrom for which creation is simple burn in nero ?

4. it is possible to also boot from existing  boot.ini into plop
or into grub4dos or into dos ,it is bit more complicated
« Last Edit: May 17, 2010, 22:56:57 PM by dukenukeme »