Author Topic: Problems when compiling plpevtch driver  (Read 11989 times)

Tomy

  • Newbie
  • *
  • Posts: 3
Problems when compiling plpevtch driver
« on: November 14, 2009, 15:31:18 PM »
When I try to compile the latest plpevtch driver on Ubuntu 09.10, I get the following error:

evdev.c: In function 'EvdevReadInput':
evdev.c:295: warning: passing argument 4 of 'TimerSet' from incompatible pointer type
/usr/include/xorg/os.h:192: note: expected 'OsTimerCallback' but argument is of type 'CARD32 (*)(struct _OsTimerRec *, CARD32,  struct _LocalDeviceRec *)'
evdev.c:371: warning: passing argument 4 of 'TimerSet' from incompatible pointer type
/usr/include/xorg/os.h:192: note: expected 'OsTimerCallback' but argument is of type 'CARD32 (*)(struct _OsTimerRec *, CARD32,  struct _LocalDeviceRec *)'
make[2]: *** [plpevtch_drv_la-evdev.lo] Error 1
make[2]: Leaving directory `/home/tom/xf86-input-plpevtch-0.4.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tom/xf86-input-plpevtch-0.4.0'
make: *** [all] Error 2

Does anybody know what I'm doing wrong?

Cheers,
Tom


Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Problems when compiling plpevtch driver
« Reply #1 on: November 14, 2009, 17:47:59 PM »
hi,
its not your fault. i will update the driver soon to fix this problem with the new xorg sources.

regards
elmar

Tomy

  • Newbie
  • *
  • Posts: 3
Re: Problems when compiling plpevtch driver
« Reply #2 on: November 17, 2009, 12:39:29 PM »
Hi,

good news... and thanks for the fast answer!!

regards
Tom

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Problems when compiling plpevtch driver
« Reply #3 on: November 18, 2009, 06:14:49 AM »
i planed to spend some time to fix it tomorrow or the day after

regards
elmar

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Problems when compiling plpevtch driver
« Reply #4 on: November 23, 2009, 14:02:30 PM »
i have some problems with fixing the bug.

Tomy

  • Newbie
  • *
  • Posts: 3
Re: Problems when compiling plpevtch driver
« Reply #5 on: November 24, 2009, 12:36:54 PM »
I'm sorry for the troubles...
Cause I'm not really familiar with this topic, I can't really help, but I could Betatest if it would help.

sf

  • Newbie
  • *
  • Posts: 1
Re: Problems when compiling plpevtch driver
« Reply #6 on: January 10, 2010, 14:24:12 PM »
Did anyone ever resolve this problem? I'm getting the same error when installing this driver on Ubuntu Netbook Remix 9.10 on a Flybook V33i.

maddis

  • Newbie
  • *
  • Posts: 1
Re: Problems when compiling plpevtch driver
« Reply #7 on: February 10, 2010, 08:12:22 AM »
I got the driver compiled for Ubuntu 9.10 and also got it working. Although this is kludge and should be used with caution. I have one problem though. When touchscreen is working the keyboard and mouse stops working!

But here are the changes:

Code: [Select]
--- evdev.c     (revision 251)
+++ evdev.c     (working copy)
@@ -106,7 +106,7 @@
  * But I need it, even if it _is_ private.
  */
 
-void xf86ActivateDevice(InputInfoPtr pInfo);
+//void xf86ActivateDevice(InputInfoPtr pInfo);
 int xold,yold;

This is the kludge part. I wasn't sure what I should put there so I just tested and with value 2 it seemed to work.
Code: [Select]
--- evdev_axes.c        (revision 251)
+++ evdev_axes.c        (working copy)
@@ -621,8 +621,7 @@
 
     if (!InitValuatorClassDeviceStruct(device, axes,
 #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 1
-                                       GetMotionHistory,
-                                       GetMotionHistorySize(),
+                                      2,
 #else
                                        miPointerGetMotionEvents,
                                        miPointerGetMotionBufferSize(),

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Problems when compiling plpevtch driver
« Reply #8 on: February 10, 2010, 08:53:11 AM »
hi,
thanks. i will take a look at it.

best regards
elmar

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Problems when compiling plpevtch driver
« Reply #9 on: April 19, 2010, 12:42:36 PM »
hi,
i updated the touchscreen driver.  compiling with the current xorg sources works now. please test it.
http://www.plop.at/en/touchscreen.html

regards
elmar
« Last Edit: April 19, 2010, 12:50:00 PM by Elmar »

Arobase

  • Newbie
  • *
  • Posts: 2
Re: Problems when compiling plpevtch driver
« Reply #10 on: June 17, 2010, 21:31:33 PM »
The mouse and keyboard issue still exist when touchscreen is active in the last version of the drivers... ^^

I had to comment out " InputDevice "touchscreen" "Pointer"" in the ServerLayout section to solve the problem.

Edit : Sorry, bad sentence ! I had to comment " InputDevice "touchscreen" "Pointer"" in the ServerLayout section to solve the problem." ^^
On my computer if this line exist in ServerLayout section, I can't use the mouse and the keyboard.
When removed, everything works...  :P
« Last Edit: June 18, 2010, 13:45:49 PM by Arobase »

almeo

  • Newbie
  • *
  • Posts: 1
Re: Problems when compiling plpevtch driver
« Reply #11 on: June 30, 2010, 18:27:19 PM »
I have the same problem : my keyboard (but not my touchpad) is inactivated
when I activate the plpevtch driver...
I am using the xorg1.7 from debian, and I first tried with my 2.6.30 kernel, then I
managed to rebuild psb kernel driver for 2.6.32 and I tried again, and it is still the
same problem...
I am using the 5.0 version of plpevtch compiled against Xorg1.7.

I would like to use the plpevtch driver because until now it has been the only one I
was able to calibrate without any problem...

Please, if some of you has any idea about the cause of the problem, I would be
glad  to know   :)

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2421
  • a command shell is enough to do amazing things
Re: Problems when compiling plpevtch driver
« Reply #12 on: June 30, 2010, 18:53:11 PM »
hmm, i try to reproduce this problem here when i have time.

regards
elmar