USB hidden boot via CDROM

Started by swan, November 28, 2009, 12:11:15 PM

Previous topic - Next topic


it has probably been mentioned somewhere in detail, but does anyone know of a link to a cd image iso that can boot usb hidden? the build i make just switches over to a period character '.' then hangs..

can anyone see a problem with my method below also? im not sure about this line 'rm iso_new/boot/boot.catalog', but ive tried a burnt copy of both ways with same result (as with the boot.catalog file has an exclusion warning when mkisofs), using plop version 5.0.3


mkdir iso
mount -o loop plpbt.iso iso/
cp -par iso/ iso_new/
umount iso
rm -rf iso
cd iso_new/boot
mkdir img
mount -o loop boot.img img/
cd img
/tftp/tools/plpcfgbt-0.4/plpcfgbt stm=hidden cnt=on cntval=1 dbt=usb plpbt.bin
cd ..
umount img
rm -rf img
cd ../..
rm iso_new/boot/boot.catalog
mkisofs -r -T -l -J -v -V PloPLinux-v5.0.3 -hide-joliet-trans-tbl -hide-rr-moved -allow-leading-dots -no-emul-boot -boot-load-size 4 -boot-info-table -b boot/boot.img -c boot/boot.catalog -o plpbt.iso iso_new/
rm -rf iso_new


first of all, you have to use the latest versions. currently its the boot manager 5.0.4 and plpcfgbt 0.6

here is a way to remaster the iso

mkdir plpoldiso
mount -o loop plpbtnoemul.iso plpoldiso
cp -avr plpoldiso  plpnewiso
plpcfgbt stm=hidden cnt=on cntval=1 dbt=usb plpnewiso/plpbt.bin

mkisofs -J -r -V plop_bootmanager \
-hide-joliet-trans-tbl -hide-rr-moved  \
-allow-leading-dots \
-o plpbtnewiso.iso -no-emul-boot -boot-load-size 4 \
-c boot.catalog -b isolinux.bin -boot-info-table -l plpnewiso

umount plpodiso
rmdir plpoldiso
rm -rf plpnewiso