Author Topic: Add library  (Read 4447 times)

acodoner

  • Newbie
  • *
  • Posts: 10
Add library
« on: December 14, 2009, 18:28:53 PM »
Hello,

The version of mkswap that comes with PLOPLinux doesn't accept the UUID parameter. I have made and opt.sqfs that includes an UUID version of mkswap but it needs the library libselinux.so.1 that must be in /lib and I don't know how to add that library there. I have tried to mount the lib.sqfs in a directory and copy the file, but it doesn't work.

Thanks.

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Add library
« Reply #1 on: December 14, 2009, 18:58:21 PM »
hi,
you have to unsquashfs the lib.sqfs, copy the lib into the directory and create the squashfs file again with mksquashfs.

or you extract the attached file with mkswap-uuid to the myscripts directory.

i add mkswap-uuid to the next release.

regards
elmar
« Last Edit: December 14, 2009, 19:01:05 PM by Elmar »

acodoner

  • Newbie
  • *
  • Posts: 10
Re: Add library
« Reply #2 on: December 14, 2009, 19:32:18 PM »
Hello,

It worked!

Thank you

chucha

  • Newbie
  • *
  • Posts: 16
Re: Add library
« Reply #3 on: February 07, 2011, 21:50:44 PM »
 Couldn't i ask a simple question (beiing a newcomer here) -
how to import and use Midnight Commander ?
I haven't found it at Live CD, I want to situate Plop
Linux on HD, provided it will be possible to implement all acustomed things like MC.
  Thanks in advance....
 

Elmar

  • Administrator
  • Hero Member
  • *****
  • Posts: 2448
  • a command shell is enough to do amazing things
Re: Add library
« Reply #4 on: February 08, 2011, 08:47:50 AM »
i don't understand your sentence. they are a bit confused.
the midnight commander is included in every plop linux release