Plop Forum

General Category => Plop Linux => Topic started by: DanSpeed on November 15, 2014, 22:10:48 PM

Title: startx command not found
Post by: DanSpeed on November 15, 2014, 22:10:48 PM
Hi,

Linux newbie here!

I'm using Plop Linux 4.2.2. I setup Boot only with TFTP. I have opt.sqfs in ploplinux/opt/

Section 17 says "You can start Gnome with startx"

startx command returns "command not found"
usefluxbox command returns "permission denied"

Net says startx runs with root privileges, or X not installed or something about xinit  .... I'm lost.

What am I doing wrong? Thanks.
Title: Re: startx command not found
Post by: Elmar on November 16, 2014, 10:59:40 AM
hello,

boot plop linux, start "mc" and navigate to /media/ploplinux/opt. is the opt.sqfs there?

elmar
Title: Re: startx command not found
Post by: DanSpeed on November 16, 2014, 11:39:38 AM
opt.sqfs is not there, unless it's hidden. It's on the TFTP in tftpboot\ploplinux-netboot\ploplinux\opt. I assumed "copy it to the ploplinux/opt/ directory" meant on the TFTP before PXE boot.
Title: Re: startx command not found
Post by: Elmar on November 16, 2014, 11:51:35 AM
recreate the file "tftpfilelist"
Title: Re: startx command not found
Post by: DanSpeed on November 16, 2014, 12:40:35 PM
Yes your correct, I just checked and it's not listed. I will recreate it.

When I originally used the Find command you showed to generate tftpfilelist PXE boot failed and the TFTP log showed " .../ploplinux-netboot/ploplinux-netboot/..." something about not found. I manually removed ploplinux-netboot from each line in tftpfilelist and PXE boot worked.

If I create tftpfilelist now from /tftpboot the start of the file looks like this;

ploplinux-netboot
ploplinux-netboot/pxelinux.0
ploplinux-netboot/pxelinux.cfg
ploplinux-netboot/pxelinux.cfg/tftp-iso.conf


Is this correct? Maybe I'm in the wrong directory when I create it or is tftp.conf adding the extra "ploplinux-netboot" it has "..... tftpboot=192.168.2.52|tftpfilelist dir=/ploplinux" I know it's not what you showed but I couldn't figure out where the extra "ploplinux-netboot" was coming from so I removed them --- like I said total newbie!
Title: Re: startx command not found
Post by: mhe on April 02, 2015, 14:23:00 PM
I am having issues with the startx command as well.

I installed the desktop and added a regular user and startx is not found.
Title: Re: startx command not found
Post by: Elmar on April 02, 2015, 17:24:48 PM
I am having issues with the startx command as well.

I installed the desktop and added a regular user and startx is not found.

how did you add the user? with useradd or adduser?
Title: Re: startx command not found
Post by: mhe on April 02, 2015, 17:52:01 PM
I used useradd. I copied the script to create a new user that comes with Nutyx. It can be found in the aaabasicfs package. I had to change the /sbin/useradd to /usr/sbin/useradd for ploplinux.
Title: Re: startx command not found
Post by: Elmar on April 02, 2015, 18:09:28 PM
I used useradd. I copied the script to create a new user that comes with Nutyx. It can be found in the aaabasicfs package. I had to change the /sbin/useradd to /usr/sbin/useradd for ploplinux.

the environment variables or the shell entry of your user are not setup correctly.

remove your additional useradd script. remove the user with userdel -r to remove the user and its home directory. then use adduser to create the user.

useradd is a base program to add a user and has to be used with additional parameters.
adduser (in plop linux, a script written by me) does all needed configurations and runs all needed programs to create a user.

to create a user called testuser just run
adduser testuser

see also https://www.plop.at/en/ploplinux/desktop/configurations.html
Title: Re: startx command not found
Post by: mhe on April 02, 2015, 22:48:54 PM
Thanks! That worked.
I disabled the root autologin as well.
Title: Re: startx command not found
Post by: Elmar on April 03, 2015, 00:28:10 AM
great :)